zoukankan      html  css  js  c++  java
  • uva 11111

     

      Problem B - Generalized Matrioshkas 

    Vladimir worked for years making matrioshkas, those nesting dolls that certainly represent truly Russian craft. A matrioshka is a doll that may be opened in two halves, so that one finds another doll inside. Then this doll may be opened to find another one inside it. This can be repeated several times, till a final doll -that cannot be opened- is reached.

    Recently, Vladimir realized that the idea of nesting dolls might be generalized to nesting toys. Indeed, he has designed toys that contain toys but in a more general sense. One of these toys may be opened in two halves and it may have more than one toy inside it. That is the new feature that Vladimir wants to introduce in his new line of toys.

    Vladimir has developed a notation to describe how nesting toys should be constructed. A toy is represented with a positive integer, according to its size. More precisely: if when opening the toy represented by m we find the toys represented by n1, n2, ..., nr, it must be true that n1 + n2 + ... + nr < m. And if this is the case, we say that toy m contains directly the toys n1, n2, ..., nr . It should be clear that toys that may be contained in any of the toys n1, n2, ..., nr are not considered as directly contained in the toy m.

    A generalized matrioshka is denoted with a non-empty sequence of non zero integers of the form:

    a1    a2    ...    aN

    such that toy k is represented in the sequence with two integers - k and k, with the negative one occurring in the sequence first that the positive one.

    For example, the sequence

    -9     -7     -2    2     -3     -2     -1    1    2    3    7    9

    represents a generalized matrioshka conformed by six toys, namely, 1, 2 (twice), 3, 7 and 9. Note that toy 7 contains directly toys 2 and 3. Note that the first copy of toy 2 occurs left from the second one and that the second copy contains directly a toy 1. It would be wrong to understand that the first -2 and the last 2 should be paired.

    On the other hand, the following sequences do not describe generalized matrioshkas:

    • -9     -7     -2    2     -3     -1     -2    2    1    3    7    9
      because toy 2 is bigger than toy 1 and cannot be allocated inside it.
    • -9     -7     -2    2     -3     -2     -1    1    2    3    7     -2    2    9
      because 7 and 2 may not be allocated together inside 9.
    • -9     -7     -2    2     -3     -1     -2    3    2    1    7    9
      because there is a nesting problem within toy 3.

    Your problem is to write a program to help Vladimir telling good designs from bad ones.

    Input 

    The input file contains several test cases, each one of them in a separate line. Each test case is a sequence of non zero integers, each one with an absolute value less than 107.

    Output 

    Output texts for each input case are presented in the same order that input is read.

    For each test case the answer must be a line of the form


    :-) Matrioshka!


    if the design describes a generalized matrioshka. In other case, the answer should be of the form


    :-( Try again.

    Sample Input 

    -9 -7 -2 2 -3 -2 -1 1 2 3 7 9
    -9 -7 -2 2 -3 -1 -2 2 1 3 7 9
    -9 -7 -2 2 -3 -1 -2 3 2 1 7 9
    -100 -50 -6 6 50 100
    -100 -50 -6 6 45 100
    -10 -5 -2 2 5 -4 -3 3 4 10
    -9 -5 -2 2 5 -4 -3 3 4 9
    

    Sample Output 

    :-) Matrioshka!
    :-( Try again.
    :-( Try again.
    :-) Matrioshka!
    :-( Try again.
    :-) Matrioshka!
    :-( Try again.
    #include <iostream>
    #include <stack>
    #include <cstring>
    #include <cstdio>
    #include <string>
    #include <algorithm>
    #include <queue>
    #include <set>
    #include <map>
    #include <fstream>
    #include <stack>
    #include <list>
    #include <sstream>
    using namespace std;
    /*
    题意:一个可以嵌套娃娃的娃娃,然后嵌套在里面的娃娃又可以继续嵌套娃娃。
    然后要求直接嵌套在里面(内一层)的娃娃的尺寸大小之和不能超过外面的。
    (要特别注意输入)
    */
    #define ms(arr, val) memset(arr, val, sizeof(arr))
    #define N 50000
    #define INF 0x3fffffff
    #define vint vector<int>
    #define sint set<int>
    #define mint map<int, int>
    #define lint list<int>
    #define sch stack<char>
    int seq[N], sum[N], top, a;
    string line;
    void init()
    {
        ms(sum, 0);
        top = -1;
    }
    
    bool judge()
    {
        init();
        istringstream iss(line);
        while (iss>>a)
        {
            if (a < 0)
            {
                sum[++top] -= a;//记录当前层的和
                seq[top] = a;
            }
            else
            {
                if (top < 0)//序列为空
                {
                    return false;
                }
                if (-seq[top] != a)//不等
                {
                    return false;
                }
                if (-seq[top] <= sum[top + 1])//当前数字不大于内层和
                {
                    return false;
                }
                //满足条件,可匹配
                sum[top + 1] = 0;//内层和清空,不影响后面操作
                top--;
            }
        }
        return top < 0 ? true : false;
    }
    int main()
    {
        while (getline(cin, line))
        {
            cout << (judge() ? ":-) Matrioshka!" : ":-( Try again.") << endl;
        }
    
        return 0;
    }
  • 相关阅读:
    springboot -jar部署
    base64前端对登陆密码编码,后端解码
    数字择优( 计算一个数与一组数字中的哪一个数字大小最接近)
    求两个数组的最小差值
    url.openConnection()远程获取图片缺失
    HttpURLConnection 用法详解
    Eureka集群入门搭建
    Django基础(五)- form组件及django序列化
    django基础(四)- 分页组件
    Django基础(四)-cookie与session
  • 原文地址:https://www.cnblogs.com/jecyhw/p/3902991.html
Copyright © 2011-2022 走看看