zoukankan      html  css  js  c++  java
  • poj1552

                                          Doubles
    Time Limit: 1000MS   Memory Limit: 10000K
    Total Submissions: 18824   Accepted: 10846

    Description

    As part of an arithmetic competency program, your students will be given randomly generated lists of from 2 to 15 unique positive integers and asked to determine how many items in each list are twice some other item in the same list. You will need a program to help you with the grading. This program should be able to scan the lists and output the correct answer for each one. For example, given the list
    1 4 3 2 9 7 18 22

    your program should answer 3, as 2 is twice 1, 4 is twice 2, and 18 is twice 9.

    Input

    The input will consist of one or more lists of numbers. There will be one list of numbers per line. Each list will contain from 2 to 15 unique positive integers. No integer will be larger than 99. Each line will be terminated with the integer 0, which is not considered part of the list. A line with the single number -1 will mark the end of the file. The example input below shows 3 separate lists. Some lists may not contain any doubles.

    Output

    The output will consist of one line per input list, containing a count of the items that are double some other item.

    Sample Input

    1 4 3 2 9 7 18 22 0
    2 4 8 10 0
    7 5 11 13 1 3 0
    -1

    Sample Output

    3
    2
    0

    Source

    Mid-Central USA 2003
    #include <iostream>
    #include<cstring>
    using namespace std;
    
    int main()
    {
        int a[20];
        cin>>a[0];
        while(a[0]!=-1)
        {
            int n =1;
            int ans = 0;
            for(;;n++)
            {
                cin>>a[n];
                if(a[n]==0)
                    break;
            }
            for(int i=0;i<n-1;i++)
            {
                for(int j=i+1;j<n;j++)
                    if(a[i]*2==a[j]||a[i]==a[j]*2)
                    ans++;
            }
            cout<<ans<<endl;
            memset(a,0,sizeof(a));
            cin>>a[0];
        }
        return 0;
    }
  • 相关阅读:
    matlab 工具箱下载地址
    P3022 [USACO11OPEN]Odd degrees G
    P1052 过河 【dp】
    P1156 垃圾陷阱
    P1063 能量项链 【区间dp】
    P1026 统计单词个数 【dp】
    P1541 乌龟棋【记忆化搜索】
    P1736 创意吃鱼法 【dp】
    单调队列优化多重背包 洛谷P1776 宝物筛选
    单调队列 洛谷P1886 滑动窗口
  • 原文地址:https://www.cnblogs.com/jhldreams/p/3748082.html
Copyright © 2011-2022 走看看