zoukankan      html  css  js  c++  java
  • UVA 题目11300 Spreading the Wealth

     

    Problem

    A Communist regime is trying to redistribute wealth in a village. They have have decided to sit everyone around a circular table. First, everyone has converted all of their properties to coins of equal value, such that the total number of coins is divisible by the number of people in the village. Finally, each person gives a number of coins to the person on his right and a number coins to the person on his left, such that in the end, everyone has the same number of coins. Given the number of coins of each person, compute the minimum number of coins that must be transferred using this method so that everyone has the same number of coins.

    The Input

    There is a number of inputs. Each input begins with n(n<1000001), the number of people in the village. nlines follow, giving the number of coins of each person in the village, in counterclockwise order around the table. The total number of coins will fit inside an unsigned 64 bit integer.

    The Output

    For each input, output the minimum number of coins that must be transferred on a single line.

    Sample Input

     

    3
    100
    100
    100
    4
    1
    2
    5
    4
    

     

    Sample Output

     

    0
    4
    【思路】:




    C0 = 0
    C1 = A1 - M = C0 + A1 - M
    C2 = A1 - M + A2 - M = C1 + A2 - M
    ............
    Cn = An-1 - M + An - M = Cn-1 + An - M

    规律:Cn  = Cn-1 + An - M

    【代码】:

     
    /*********************************
    *   日期:2013-4-21
    *   作者:SJF0115
    *   题号: 题目11300 - Spreading the Wealth
    *   来源:http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=25&page=show_problem&problem=2275
    *   结果:AC
    *   来源:UVA
    *   总结:
    **********************************/
    #include<stdio.h>
    #include<stdlib.h>
    
    int Money[1000001],C[1000001];
    
    int cmp(const void *a,const void *b){
    	return *(int *)a - *(int *)b;
    }
    //绝对值
    int abs(int a,int b){
    	if(a < b){
    		return b - a;
    	}
    	else{
    		return a - b;
    	}
    }
    
    int main ()
    {
    	long long int i,N,Min,Sum,M;
    	//freopen("C:\\Users\\XIAOSI\\Desktop\\acm.txt","r",stdin);
    	while(scanf("%lld",&N) != EOF){
    		Sum = 0;
    		Min = 0;
    		//N个人
    		for(i = 0;i < N;i++){
    			scanf("%d",&Money[i]);
    			Sum += Money[i];
    		}
    		//平均值
    		M = Sum / N;
    		C[0] = 0;
    		//初始化C数组
    		for(i = 1;i < N;i++){
    			C[i] = C[i-1] + Money[i] - M;
    		}
    		//排序,选择中位数
    		qsort(C,N,sizeof(int),cmp);
    		long long int x1 = C[N/2];
    		//计算转移的金币数
    		for(i = 0;i < N;i++){
    			Min += abs(x1,C[i]);
    		}
    		printf("%lld\n",Min);
    	}
    	return 0;
    }
    
    


    注意:int越界 用long long int 













  • 相关阅读:
    find文件后cp、rm
    值得加分的
    对老师的评价
    关于Statement 与 PreparedStatement
    每日日报2021.1.14
    每日日报2020.1.12
    每日日报2021.1.11
    给自己算的加分项
    期末了,给老师提建议。
    每日日报2020 12/19
  • 原文地址:https://www.cnblogs.com/jiangu66/p/3035921.html
Copyright © 2011-2022 走看看