zoukankan      html  css  js  c++  java
  • HDU1718:Rank

    Problem Description
    Jackson wants to know his rank in the class. The professor has posted a list of student numbers and marks. Compute Jackson’s rank in class; that is, if he has the top mark(or is tied for the top mark) his rank is 1; if he has the second best mark(or is tied) his rank is 2, and so on.
     
    Input
    The input consist of several test cases. Each case begins with the student number of Jackson, an integer between 10000000 and 99999999. Following the student number are several lines, each containing a student number between 10000000 and 99999999 and a mark between 0 and 100. A line with a student number and mark of 0 terminates each test case. There are no more than 1000 students in the class, and each has a unique student number.
     
    Output
    For each test case, output a line giving Jackson’s rank in the class.
     
    Sample Input
    20070101 20070102 100 20070101 33 20070103 22 20070106 33 0 0
     
    Sample Output
    2
     


     

    只需要找出成绩比本人成绩高的个数再加1就可以了

    #include <stdio.h>
    #include <string.h>
    #include <algorithm>
    using namespace std;
    int cmp(const int x,const int y)
    {
        return x > y;
    }
    int main()
    {
        char flag[100],a[100];
        int k,b,tem,num[1005];
        while(~scanf("%s",flag))
        {
            k = 0;
            while(~scanf("%s%d",&a,&b))
            {
                if(!strcmp(a,"0") && b==0) break;
                if(!strcmp(a,flag))
                    tem = b;
                num[k++] = b;
            }
            sort(num,num+k,cmp);
            int cnt = 1;
            for(int i = 0; i<k; i++)
            {
                if(num[i] > tem)
                    cnt++;
                else
                    break;
            }
            printf("%d\n",cnt);
        }
        return 0;
    }
    


     

  • 相关阅读:
    v-cloak无效解决方法
    堆栈,托管堆,堆,栈的区别
    2018-3-25至2018-8-9的日语笔记
    windows下远程连接redis
    windows cmd打开共享文件夹
    C#数据分组
    安装pyspider遇到的坑
    argument 1 must be 2-item sequence, not int
    python,pip环境变量设置
    python编程学习--Pygame
  • 原文地址:https://www.cnblogs.com/jiangu66/p/3038602.html
Copyright © 2011-2022 走看看