zoukankan      html  css  js  c++  java
  • POJ 2356 Find a multiple

    Find a multiple
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 4642   Accepted: 2020   Special Judge

    Description

    The input contains N natural (i.e. positive integer) numbers ( N <= 10000 ). Each of that numbers is not greater than 15000. This numbers are not necessarily different (so it may happen that two or more of them will be equal). Your task is to choose a few of given numbers ( 1 <= few <= N ) so that the sum of chosen numbers is multiple for N (i.e. N * k = (sum of chosen numbers) for some natural number k).

    Input

    The first line of the input contains the single number N. Each of next N lines contains one number from the given set.

    Output

    In case your program decides that the target set of numbers can not be found it should print to the output the single number 0. Otherwise it should print the number of the chosen numbers in the first line followed by the chosen numbers themselves (on a separate line each) in arbitrary order.

    If there are more than one set of numbers with required properties you should print to the output only one (preferably your favorite) of them.

    Sample Input

    5
    1
    2
    3
    4
    1
    

    Sample Output

    2
    2
    3
    

    Source

      考察点: 鸽巢原理
    #include <stdio.h>
    #include <string.h>
    #include <math.h>
    int sum[11000],a[11000],pt[11000];
    int main()
    {
        int i,j,n,m,s,t,key;
        while(scanf("%d",&n)!=EOF)
        {
           
            key=-1;
            memset(sum,0,sizeof(sum));
            memset(pt,0,sizeof(pt));
            for(i=1;i<=n;i++)
            {
                scanf("%d",&a[i]);
                sum[i]=sum[i-1]+a[i];
                if(sum[i]%n==0)
                {
                    key=i;
                }
            }
            if(key!=-1)
            {
                printf("%d\n",key);
                for(i=1;i<=key;i++)
                {
                    printf("%d\n",a[i]);
                }
                continue;
            }
            for(i=1;i<=n;i++)
            {
                m=sum[i]%n;
                if(!pt[m])
                {
                    pt[m]=i;
                }else
                {
                    break;
                }
            }
            printf("%d\n",i-pt[m]);
            for(j=pt[m]+1; j<=i ;j++)
            {
                printf("%d\n",a[j]);
            }
        }
        return 0;
    }
    

  • 相关阅读:
    命令安装mongod作为服务启动
    npm命令
    win服务
    win进程操作
    【数据结构与算法之美】7.排序算法之冒泡、选择、插入
    【leetcode】23.合并K个排序链表
    【leetcode】141.环形链表
    【数据结构与算法之美】6.环形队列
    【数据结构与算法之美】5.基于链表实现队列
    【数据结构与算法之美】4.基于数组实现队列
  • 原文地址:https://www.cnblogs.com/jiangu66/p/3057292.html
Copyright © 2011-2022 走看看