zoukankan      html  css  js  c++  java
  • 12503

      Robot Instructions 

    You have a robot standing on the origin of x axis. The robot will be given some instructions. Your task is to predict its position after executing all the instructions.

     

    • LEFT: move one unit left (decrease p by 1, where p is the position of the robot before moving)
    • RIGHT: move one unit right (increase p by 1)
    • SAME AS i: perform the same action as in the i-th instruction. It is guaranteed thati is a positive integer not greater than the number of instructions before this.

     

    Input 

    The first line contains the number of test cases  T  ( T$ le$100 ). Each test case begins with an integer  n  (   1$ le$n$ le$100 ), the number of instructions. Each of the following  n lines contains an instruction.

     

    Output 

    For each test case, print the final position of the robot. Note that after processing each test case, the robot should be reset to the origin.

     

    Sample Input 

     

    2
    3
    LEFT
    RIGHT
    SAME AS 2
    5
    LEFT
    SAME AS 1
    SAME AS 2
    SAME AS 1
    SAME AS 4
    

     

    Sample Output 

     

    1
    -5
    

     

    #include<iostream>
    #include<cstring>
    #include<cstdio>
    #include<cctype>
    using namespace std;
    int main()
    {
    	int t,n,p,a[105];
    	char s[10];
    	cin>>t;
    	while(t--)
    	{
    		p=0;
    		cin>>n;
    		getchar();
    		for(int i=1;i<=n;i++)
    		{
    			gets(s);
    			if(strlen(s)==4)
    				a[i]=-1;
    			else if(strlen(s)==5)
    				a[i]=1;
    			else if(!isdigit(s[strlen(s)-2]))
    				a[i]=a[s[strlen(s)-1]-'0'];
    			else 
    				a[i]=a[s[strlen(s)-1]-'0'+10*(s[strlen(s)-2]-'0')];
    			p+=a[i];
    		}
    		cout<<p<<endl;
    	}
    	return 0;
    }
  • 相关阅读:
    codeforces 814B An express train to reveries
    codeforces 814A An abandoned sentiment from past
    codeforces 785D D. Anton and School
    codeforces 785C Anton and Fairy Tale
    codeforces 791C Bear and Different Names
    AOP详解
    Spring集成JUnit测试
    Spring整合web开发
    IOC装配Bean(注解方式)
    IOC装配Bean(XML方式)
  • 原文地址:https://www.cnblogs.com/jiangu66/p/3172229.html
Copyright © 2011-2022 走看看