zoukankan      html  css  js  c++  java
  • HDU--1213--How Many Tables--并查集

    How Many Tables

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 9066    Accepted Submission(s): 4429


    Problem Description
    Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

    One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

    For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.
     


     

    Input
    The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.
     


     

    Output
    For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.
     


     

    Sample Input
    2 5 3 1 2 2 3 4 5 5 1 2 5
     


     

    Sample Output
    2 4

    #include <iostream>
    using namespace std;
    int father[1111];
    int Find(int a)  //找到祖先并所有家族成员指向祖先
    {
     return father[a]==a?a:father[a]=Find(father[a]);
    }
    void Union(int a,int b)  //把a家族并入b家族,a祖先指向b祖先
    {
     if(father[a]!=father[b])
     father[Find(a)]=Find(b);
    }
    int main (void)
    {
     int t,n,m,i,j,k,l;
     cin>>t;
     while(t--&&cin>>n>>m)
     {
      for(i=1;i<=n;i++)
       father[i]=i;
      for(i=0;i<m;i++)
      {
       cin>>k>>l;
       Union(k,l);
      }
      for(i=1,j=0;i<=n;i++)
      if(father[i]==i)  //计算有多少独立个体即计算多少家族即计算祖先数
      {
       j++;
      }
      cout<<j<<endl;
     }
     return 0;
    }

  • 相关阅读:
    如何重启apache2服务
    ubuntu设置不睡眠的方法
    linux环境下安装varnish
    PHP 开发者该知道的 5 个 Composer 小技巧
    dl, dt, dd /line-height /loat /vertical-align 问题
    针对老式浏览器(主要是IE6、7、8)的css3-mediaqueries.js自适应布局
    三栏网页宽度自适应布局方法
    vue.js开发环境搭建
    vue.js之个人总结
    less学习:基础语法总结
  • 原文地址:https://www.cnblogs.com/jiangu66/p/3198782.html
Copyright © 2011-2022 走看看