zoukankan      html  css  js  c++  java
  • Diamond Collector (动态规划)

    问题 I: Diamond Collector

    时间限制: 1 Sec  内存限制: 64 MB
    提交: 22  解决: 7
    [提交][状态][讨论版]

    题目描述

    Bessie the cow, always a fan of shiny objects, has taken up a hobby of mining diamonds in her spare time! She has collected N diamonds (N≤50,000) of varying sizes, and she wants to arrange some of them in a pair of display cases in the barn.

    Since Bessie wants the diamonds in each of the two cases to be relatively similar in size, she decides that she will not include two diamonds in the same case if their sizes differ by more than K
    (two diamonds can be displayed together in the same case if their sizes differ by exactly K). Given K, please help Bessie determine the maximum number of diamonds she can display in both cases together.

    输入

    The first line of the input file contains N and K (0≤K≤1,000,000,000). The next N lines each contain an integer giving the size of one of the diamonds. All sizes will be positive and will not exceed 1,000,000,000.

    输出

     Output a single positive integer, telling the maximum number of diamonds that Bessie can showcase in total in both the cases.

    样例输入

    7 3
    10
    5
    1
    12
    9
    5
    14
    

    样例输出

    5
    #include <iostream>
    #include <cstring>
    #include <cstdio>
    #include <cstring>
    #include <algorithm>
    #include <cmath>
    #include <time.h>
    #include <string>
    #include <map>
    #include <stack>
    #include <vector>
    #include <set>
    #include <queue>
    #define inf 0x3f3f3f3f
    #define mod 1000000007
    typedef long long ll;
    using namespace std;
    const int N=50010;
    int n,dp[N],len,g[N];
    ll k,a[N];
    int w[21][21];
    int flag=0;
    int vis[10000]={0};
    string str[21],ch;
    int maxn=1;
    map<string,int>p,pp;
     
     
    int main() {
        memset(dp,0,sizeof(dp));
        cin>>n>>k;
        for(int i=1;i<=n;i++)cin>>a[i];
        sort(a+1,a+n+1);
        int m=1,r=1;
        for(int i=1;i<=n;i++)
        {
           while(a[r+1]-a[i]<=k&&r<n) r++;
           dp[i]=r-i+1;
        }
        for(int i=n;i>=1;i--)
            g[i]=max(g[i+1],dp[i]);
        int ans=0;
        for(int i=1;i<=n;i++)
            ans=max(ans,dp[i]+g[i+dp[i]]);
        cout<<ans<<endl;
        return 0;
    }
    View Code
  • 相关阅读:
    git 命令速查及使用
    Centos6.5 LAMP环境源码包安装与配置,附安装包百度网盘地址 (转做笔记)
    不再为Apache进程淤积、耗尽内存而困扰((转))
    centos6.5 安装linux 环境
    window 配置wnmp(转下整理 ,全)
    mac下安装 xampp 无法启动apache (转,留用)
    Git命令行(转用于学习和记录)
    apache 局域网访问
    华为云GaussDB(for opengauss)如何绑定公网,实现putty的远程访问gaussdb数据库。
    Day9 打卡acwing.429 奖学金
  • 原文地址:https://www.cnblogs.com/jianrenfang/p/5719856.html
Copyright © 2011-2022 走看看