zoukankan      html  css  js  c++  java
  • poj 2503 查字典

    Description

    You have just moved from Waterloo to a big city. The people here speak an incomprehensible dialect of a foreign language. Fortunately, you have a dictionary to help you understand them.

    Input

    Input consists of up to 100,000 dictionary entries, followed by a blank line, followed by a message of up to 100,000 words. Each dictionary entry is a line containing an English word, followed by a space and a foreign language word. No foreign word appears more than once in the dictionary. The message is a sequence of words in the foreign language, one word on each line. Each word in the input is a sequence of at most 10 lowercase letters.

    Output

    Output is the message translated to English, one word per line. Foreign words not in the dictionary should be translated as "eh".

    Sample Input

    dog ogday
    cat atcay
    pig igpay
    froot ootfray
    loops oopslay
    
    atcay
    ittenkay
    oopslay
    

    Sample Output

    cat
    eh
    loops

    其实用cin输入输出也可以
    map<T,T>dd;
    以及gets(a)与sscanf(a,"%s",str)配合用法;
    a为char a[45];
    #include<cstdio>
    #include<string>
    #include<iostream>
    #include<map>
    using namespace std;
    
    int main()
    {    map<string,string>dic;
        char a[11],b[11];
        int i=0;
     char str[21];
        while(gets(str))
        {
          if(str[0]==''){break;}
          sscanf(str,"%s %s",a,b);
         dic[b]=a;
        }
        char c[11];
     string qq;
        while(scanf("%s",c)!=EOF)
            {
                 string s=c;
               qq=dic[s];
               if(qq.length()==0)cout<<"eh"<<endl;
               else cout<<qq<<endl;
    
            }
    
        return 0;
    }
  • 相关阅读:
    HTTP content-type及POST提交数据方式
    Spring Kafka
    Spring动态数据源-AbstractRoutingDataSource(实现分库分表)
    HTTP通信安全和Web攻击技术
    HTTP协议
    zookeeper 图形化的客户端工具:ZooInspector
    centos 中v2r客户端配置实例
    查看视频详细信息
    centos7 创建用户
    logstash
  • 原文地址:https://www.cnblogs.com/jin-nuo/p/5540287.html
Copyright © 2011-2022 走看看