zoukankan      html  css  js  c++  java
  • B

    "OK, you are not too bad, em... But you can never pass the next test." feng5166 says.

    "I will tell you an odd number N, and then N integers. There will be a special integer among them, you have to tell me which integer is the special one after I tell you all the integers." feng5166 says. 

    "But what is the characteristic of the special integer?" Ignatius asks. 

    "The integer will appear at least (N+1)/2 times. If you can't find the right integer, I will kill the Princess, and you will be my dinner, too. Hahahaha....." feng5166 says. 

    Can you find the special integer for Ignatius? 

    InputThe input contains several test cases. Each test case contains two lines. The first line consists of an odd integer N(1<=N<=999999) which indicate the number of the integers feng5166 will tell our hero. The second line contains the N integers. The input is terminated by the end of file. 
    OutputFor each test case, you have to output only one line which contains the special number you have found. 
    Sample Input

    5
    1 3 2 3 3
    11
    1 1 1 1 1 5 5 5 5 5 5
    7
    1 1 1 1 1 1 1

    Sample Output

    3
    5
    1


    这题直接开数组也能过。还可以引入一个cnt,输入元素与上一个元素相同,cnt增加,否则cnt减少,当cnt为零时记录输入元素,因为所求数字至少出现(N+1)/2次,所以最后记录元素就是所求元素
    #include <iostream>
    #include <string>
    #include<cstring>
    #include<cstdio>
    #include <vector>
    #include <algorithm>
    using namespace std;
    int main()
    {
        int n;
        while(scanf("%d",&n)!=EOF)
        {
            int tmp,cnt = 1,cur;
            scanf("%d",&tmp);
            for(int i=1;i<n;i++)
            {
                scanf("%d",&cur);
                if(cur==tmp)
                    cnt++;
                else
                    cnt--;
                if(cnt==0)
                {
                    tmp = cur;
                    cnt = 1;
                }
            }
            cout<<tmp<<endl;
        }
    }
  • 相关阅读:
    RPC 接口必须是业务职责
    一套高可用、易伸缩、高并发的IM群聊、单聊架构方案设计实践
    t
    hessian-serialization
    服务拆分 服务设计
    灰度架构设计方案
    有赞发号器多机房方案
    解析MySQL中存储时间日期类型的选择问题
    t
    在阿里,我如何做好技术项目管理?
  • 原文地址:https://www.cnblogs.com/joeylee97/p/6616039.html
Copyright © 2011-2022 走看看