zoukankan      html  css  js  c++  java
  • E

    Nowadays, a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popular in HDU. Maybe you are a good boy, and know little about this game, so I introduce it to you now. 



    The game can be played by two or more than two players. It consists of a chessboard(棋盘)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In the course of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping can go from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his jumping solution. Note that your score comes from the sum of value on the chessmen in you jumping path. 
    Your task is to output the maximum value according to the given chessmen list. 

    InputInput contains multiple test cases. Each test case is described in a line as follow: 
    N value_1 value_2 …value_N 
    It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int. 
    A test case starting with 0 terminates the input and this test case is not to be processed. 
    OutputFor each case, print the maximum according to rules, and one line one case. 
    Sample Input

    3 1 3 2
    4 1 2 3 4
    4 3 3 2 1
    0

    Sample Output

    4
    10
    3
    像这样对顺序有要求的DP,可以想一下最长递增子序列思路
    #include <iostream>
    #include <string>
    #include<cstring>
    #include<cstdio>
    #include <vector>
    #include <algorithm>
    using namespace std;
    #define MAXN 1004
    typedef long long LL;
    /*
    从下向上叠箱子,可以看作求最长递增子序列的和.
    */
    int main()
    {
        int n,a[MAXN],dp[MAXN];
        while(scanf("%d",&n),n)
        {
            int ans = -1;
            for(int i=0;i<n;i++) 
            {
                scanf("%d",&a[i]);
                dp[i] = a[i];
            }
            for(int i=1;i<n;i++)
            {
                for(int j=0;j<i;j++)
                {
                    if(a[i]>a[j])
                        dp[i] = max(dp[i],dp[j]+a[i]);
                    ans = max(dp[i],ans);
                }
            }
            cout<<ans<<endl;
        }
    }
  • 相关阅读:
    Django 框架 # 51
    Django 框架 介绍# 51
    前端之Bootstrap框架 # 50
    phpcms调用一个指定的栏目的url和栏目名称
    phpcms导航栏调用二级栏目
    彻底弄懂JS的事件冒泡和事件捕获
    toggle 方法的使用
    关于内层DIV设置margin-top不起作用的解决方案
    phpmyadmin导入数据库大小限制修改
    phpcms v9 的表单向导功能的使用方法
  • 原文地址:https://www.cnblogs.com/joeylee97/p/6616847.html
Copyright © 2011-2022 走看看