zoukankan      html  css  js  c++  java
  • poj3253 Fence Repair

    Description

    Farmer John wants to repair a small length of the fence around the pasture. He measures the fence and finds that he needs N (1 ≤ N ≤ 20,000) planks of wood, each having some integer length Li (1 ≤ Li ≤ 50,000) units. He then purchases a single long board just long enough to saw into the N planks (i.e., whose length is the sum of the lengths Li). FJ is ignoring the "kerf", the extra length lost to sawdust when a sawcut is made; you should ignore it, too.

    FJ sadly realizes that he doesn't own a saw with which to cut the wood, so he mosies over to Farmer Don's Farm with this long board and politely asks if he may borrow a saw.

    Farmer Don, a closet capitalist, doesn't lend FJ a saw but instead offers to charge Farmer John for each of the N-1 cuts in the plank. The charge to cut a piece of wood is exactly equal to its length. Cutting a plank of length 21 costs 21 cents.

    Farmer Don then lets Farmer John decide the order and locations to cut the plank. Help Farmer John determine the minimum amount of money he can spend to create the N planks. FJ knows that he can cut the board in various different orders which will result in different charges since the resulting intermediate planks are of different lengths.

    Input

    Line 1: One integer N, the number of planks 
    Lines 2..N+1: Each line contains a single integer describing the length of a needed plank

    Output

    Line 1: One integer: the minimum amount of money he must spend to make N-1 cuts

    Sample Input

    3
    8
    5
    8

    Sample Output

    34
    题目大意:FJ需要修补牧场的围栏,他需要 N 块长度为 Li 的木头(N planks of woods)。开始时,FJ只有一块无限长的木板,因此他需要把无限长的木板锯成 N 块长度
    
    为 Li 的木板,Farmer Don提供FJ锯子,但必须要收费的,收费的标准是对应每次据出木块的长度,比如说测试数据中 5 8 8,一开始,
    FJ需要在无限长的木板上锯下长度 21 的木板(5+8+8=21),第二次锯下长度为 5 的木板,第三次锯下长度为 8 的木板,至此就可以将长度分别为 5 8 8 的木板找出
    题目思路:题意可以转换成赫夫曼树的构造过程,用数组存储所有需要的木板长度,然后排序,将前两段最短的生成新节点,将生成的新节点进行插入排序,最后统计生成赫夫曼树后所有花费。
    #include<iostream>
    #include<algorithm>
    #include<string.h>
    
    
    using namespace std;
    
    
    int main(){
        int q[20005];
        memset(q,0,sizeof(q));
    
        int i,j,n,sum=0;
        long long ans=0;
    
        cin>>n;
        for(i=0;i<n;i++){
            cin>>q[i];
        }
        sort(q,q+n);//将需要的木板排序
    
        for(i=0;i<n-1;i++){
            sum = q[i]+q[i+1];
            ans+=sum;//对需要的花费进行统计
            for(j=i+2;j<n;j++)
            {
                if(sum>q[j]){
                    q[j-1]=q[j];
                }
                else{
                    q[j-1]=sum;
                    break;
                }
                
            }//for循环插入排序
            if(j==n)
                q[j-1]=sum;//for循环不起作用跳出,即sum比所有剩余元素还要大的情况
        }
        cout<<ans<<endl;
    }
  • 相关阅读:
    IT asset register
    微前端
    强缓存和弱缓存(协商缓存)
    比较运算规则 == 、 ===、Object.is 和 ToPrimitive 方法 [[DefaultValue]] (hint)
    事件冒泡、事件捕获、事件委托
    mysql服务没有响应控制功能
    React 项目中有哪些细节可以优化?实际开发中都做过哪些性能优化
    算法的时间复杂度与空间复杂度
    算法:42.接雨水
    解决每次git pull、git push都需要输入账号和密码的问题
  • 原文地址:https://www.cnblogs.com/jokerspace/p/6752620.html
Copyright © 2011-2022 走看看