zoukankan      html  css  js  c++  java
  • HDU 3038(权值并查集)

    How Many Answers Are Wrong

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 21469    Accepted Submission(s): 7404


    Problem Description
    TT and FF are ... friends. Uh... very very good friends -________-b

    FF is a bad boy, he is always wooing TT to play the following game with him. This is a very humdrum game. To begin with, TT should write down a sequence of integers-_-!!(bored).

    Then, FF can choose a continuous subsequence from it(for example the subsequence from the third to the fifth integer inclusively). After that, FF will ask TT what the sum of the subsequence he chose is. The next, TT will answer FF's question. Then, FF can redo this process. In the end, FF must work out the entire sequence of integers.

    Boring~~Boring~~a very very boring game!!! TT doesn't want to play with FF at all. To punish FF, she often tells FF the wrong answers on purpose.

    The bad boy is not a fool man. FF detects some answers are incompatible. Of course, these contradictions make it difficult to calculate the sequence.

    However, TT is a nice and lovely girl. She doesn't have the heart to be hard on FF. To save time, she guarantees that the answers are all right if there is no logical mistakes indeed.

    What's more, if FF finds an answer to be wrong, he will ignore it when judging next answers.

    But there will be so many questions that poor FF can't make sure whether the current answer is right or wrong in a moment. So he decides to write a program to help him with this matter. The program will receive a series of questions from FF together with the answers FF has received from TT. The aim of this program is to find how many answers are wrong. Only by ignoring the wrong answers can FF work out the entire sequence of integers. Poor FF has no time to do this job. And now he is asking for your help~(Why asking trouble for himself~~Bad boy)
     
    Input
    Line 1: Two integers, N and M (1 <= N <= 200000, 1 <= M <= 40000). Means TT wrote N integers and FF asked her M questions.

    Line 2..M+1: Line i+1 contains three integer: Ai, Bi and Si. Means TT answered FF that the sum from Ai to Bi is Si. It's guaranteed that 0 < Ai <= Bi <= N.

    You can assume that any sum of subsequence is fit in 32-bit integer.
     
    Output
    A single line with a integer denotes how many answers are wrong.
     
    Sample Input
    10 5 1 10 100 7 10 28 1 3 32 4 6 41 6 6 1
     
    Sample Output
    1

     题意 “:n长度的数,m个询问,每行询问 三个整数,l,r,dis。代表第l到r的和是dis,问你有多少询问是错误的。

    思路:带权并查集,首先要注意左闭右开= =,没啥特色吧,我是把并查集的root默认为最小的 ,

        当l-1 的root小于r的root,遍把r的root接到l-1的root,d[fy]更新公式d[fy] = dis + d[x] - d[y];

          反者---------------------------------------------------------------,d[fx]的更新公式d[fx] = d[y] - dis - d[x];(这两个公式推了好久= =)

    #include <iostream>
    #include <cmath>
    #include <cstdio>
    #include <cstring>
    #include <string>
    #include <map>
    #include <iomanip>
    #include <algorithm>
    #include <queue>
    #include <stack>
    #include <set>
    #include <vector>
    //const int maxn = 1e5+5;
    #define ll long long
    ll gcd(ll a,ll b){return b?gcd(b,a%b):a;}
    ll lcm(ll a,ll b){return a/gcd(a,b)*b;}
    
    #define MAX INT_MAX
    #define FOR(i,a,b) for( int i = a;i <= b;++i)
    #define bug cout<<"--------------"<<endl
    using namespace std;
    int fa[210000],d[210000];
    int n,m,ans;
    int Find(int x)
    {
        if(x == fa[x]) return x;
        int root = Find(fa[x]);
        d[x] += d[fa[x]];
        return fa[x] = root;
    }
    void solve(int x ,int y,int dis)
    {
        int fx = Find(x);
        int fy = Find(y);
        if(fx == fy)
        {
            if(d[x] + dis != d[y])
            {
                ans++;
                return ;
            }
        }
        else if(fx < fy)
        {
            fa[fy] = fx;
            d[fy] = dis + d[x] - d[y];
        }
        else
        {
            fa[fx] = fy;
            d[fx] = d[y] - dis - d[x];
        }
    
    }
    int main()
    {
    
        while(cin>>n>>m)
        {
            ans = 0;
            memset(d,0,sizeof(d));
            for(int i = 1;i<=200003;++i) fa[i] = i;
            while(m--)
            {
                int l,r,dis;
                cin>>l>>r>>dis;
                solve(l-1,r,dis);
            }
            cout<<ans<<endl;
        }
    
    }
  • 相关阅读:
    考拉兹猜想,100万以内的数
    给任意a、b、c三个数作为边盘都是否能构成三角形
    计数算法-对200万考生的成绩就行排序
    冒泡排序
    插入排序
    Echarts
    vue+tinymce
    java RestTemplate.postForObject请求传参
    java计算今天起后7天时间 +昨天八点+今天前7天的日期
    layui+echarts+动态数据
  • 原文地址:https://www.cnblogs.com/jrfr/p/11405778.html
Copyright © 2011-2022 走看看