zoukankan      html  css  js  c++  java
  • Ombrophobic Bovines 分类: POJ 图论 最短路 查找 2015-08-10 20:32 2人阅读 评论(0) 收藏

    Ombrophobic Bovines
    Time Limit: 1000MS Memory Limit: 65536K
    Total Submissions: 16539 Accepted: 3605

    Description
    FJ’s cows really hate getting wet so much that the mere thought of getting caught in the rain makes them shake in their hooves. They have decided to put a rain siren on the farm to let them know when rain is approaching. They intend to create a rain evacuation plan so that all the cows can get to shelter before the rain begins. Weather forecasting is not always correct, though. In order to minimize false alarms, they want to sound the siren as late as possible while still giving enough time for all the cows to get to some shelter.

    The farm has F (1 <= F <= 200) fields on which the cows graze. A set of P (1 <= P <= 1500) paths connects them. The paths are wide, so that any number of cows can traverse a path in either direction.

    Some of the farm’s fields have rain shelters under which the cows can shield themselves. These shelters are of limited size, so a single shelter might not be able to hold all the cows. Fields are small compared to the paths and require no time for cows to traverse.

    Compute the minimum amount of time before rain starts that the siren must be sounded so that every cow can get to some shelter.

    Input
    * Line 1: Two space-separated integers: F and P

    • Lines 2..F+1: Two space-separated integers that describe a field. The first integer (range: 0..1000) is the number of cows in that field. The second integer (range: 0..1000) is the number of cows the shelter in that field can hold. Line i+1 describes field i.

    • Lines F+2..F+P+1: Three space-separated integers that describe a path. The first and second integers (both range 1..F) tell the fields connected by the path. The third integer (range: 1..1,000,000,000) is how long any cow takes to traverse it.

    Output
    * Line 1: The minimum amount of time required for all cows to get under a shelter, presuming they plan their routes optimally. If it not possible for the all the cows to get under a shelter, output “-1”.

    Sample Input

    3 4
    7 2
    0 4
    2 6
    1 2 40
    3 2 70
    2 3 90
    1 3 120

    Sample Output

    110

    Hint
    OUTPUT DETAILS:

    In 110 time units, two cows from field 1 can get under the shelter in that field, four cows from field 1 can get under the shelter in field 2, and one cow can get to field 3 and join the cows from that field under the shelter in field 3. Although there are other plans that will get all the cows under a shelter, none will do it in fewer than 110 time units.

    Source
    USACO 2005 March Gold
    一道神伤的题,敲完Dinic结果不对,以为自己的最大流敲错了,后来知道要拆点,搞了一天的TLE加WA

    #include <map>
    #include <list>
    #include <climits>
    #include <cmath>
    #include <queue>
    #include <stack>
    #include <string>
    #include <cstdio>
    #include <cstring>
    #include <cstdlib>
    #include <iostream>
    #include <algorithm>
    using namespace std;
    #define LL long long
    #define PI acos(-1.0)
    #define MMM 0x3f3f3f3f
    #define RR freopen("input.txt","r",stdin)
    #define WW freopen("output.txt","w",stdout)
    
    const LL INF = 1e15;
    
    const int Max = 410;
    
    struct node
    {
        int v;
        int w;
        int next;
    } Edge[321000];
    LL M[Max][Max];
    int ww[Max],c[Max];
    int F,P,top;
    int s,t;
    int vis[Max];
    int Sum;
    int Head[Max],cur[Max];
    void Build(int u,int v,int w)
    {
        Edge[top].v=v;
        Edge[top].w=w;
        Edge[top].next=Head[u];
        Head[u]=top++;
        Edge[top].v=u;
        Edge[top].w=0;
        Edge[top].next=Head[v];
        Head[v]=top++;
    }
    void init()
    {
        for(int i=1; i<=F; i++)
        {
            for(int j=i; j<=F; j++)
            {
    
                M[i][j]=M[j][i]=INF;
            }
        }
    }
    void Floyd()
    {
        for(int k=1; k<=F; k++)
        {
            for(int i=1; i<=F; i++)
            {
                for(int j=1; j<=F; j++)
                {
                    if(M[i][j]>M[i][k]+M[k][j])
                        M[i][j]=M[i][k]+M[k][j];
                }
            }
        }
    }
    void ReBuild(LL MaxNum)
    {
        top=0;
        memset(Head,-1,sizeof(Head));
        for(int i=1; i<=F; i++)
        {
            Build(s,i,ww[i]);
            Build(i+F,t,c[i]);
        }
        for(int i=1; i<=F; i++)
        {
            Build(i,i+F,MMM);
        }
        for(int i=1; i<=F; i++)
        {
            for(int j=i+1; j<=F; j++)
            {
                if(M[i][j]<=MaxNum)
                {
                    Build(i,j+F,MMM);
                    Build(j,i+F,MMM);
                }
            }
        }
    }
    int BFS()
    {
        memset(vis,0,sizeof(vis));
        queue<int >Q;
        Q.push(0);
        vis[0]=1;
        while(!Q.empty())
        {
            int a=Q.front();
            Q.pop();
            for(int i=Head[a]; i!=-1; i=Edge[i].next)
            {
                if(Edge[i].w>0&&!vis[Edge[i].v])
                {
                    vis[Edge[i].v]=vis[a]+1;
                    Q.push(Edge[i].v);
                }
            }
        }
        return vis[t];
    }
    int DFS(int star,int num)
    {
        if(star==t||num==0)
        {
            return num;
        }
        int data=0;
        int ant;
        for(int& i=cur[star]; i!=-1; i=Edge[i].next)//不加&会超时,请大神指教
        {
            if(vis[star]+1==vis[Edge[i].v]&&(ant=DFS(Edge[i].v,min(Edge[i].w,num)))>0)
            {
                Edge[i].w-=ant;
                Edge[i^1].w+=ant;
                num-=ant;
                data+=ant;
                if(!num)
                {
                    break;
                }
            }
        }
        return data;
    }
    int Dinic()
    {
        int ant=0;
        while(BFS())
        {
            for(int i=0; i<=t; i++)
            {
                cur[i]=Head[i];
            }
            ant+=DFS(s,MMM);
        }
        return ant;
    }
    void Search()
    {
        LL L=1,R=INF-1;
        LL ans=-1;
        int ant;
        while(L<=R)
        {
            LL mid=(L+R)/2;
            ReBuild(mid);
            ant=Dinic();
            if(ant>=Sum)
            {
                ans=mid;
                R=mid-1;
            }
            else
            {
                L=mid+1;
            }
        }
        cout<<ans<<endl;
    }
    int main()
    {
        int u,v,w;
        while(~scanf("%d%d",&F,&P))
        {
            init();
            Sum=0;
            s=0;
            t=2*F+1;
            for(int i=1; i<=F; i++)
            {
                scanf("%d%d",&ww[i],&c[i]);
                Sum+=ww[i];
            }
            for(int i=1; i<=P; i++)
            {
                scanf("%d %d %d",&u,&v,&w);
                if(M[u][v]>w)
                {
                    M[u][v]=M[v][u]=w;
                }
            }
            Floyd();
            Search();
        }
        return 0;
    }
    

    版权声明:本文为博主原创文章,未经博主允许不得转载。

  • 相关阅读:
    201521123051 《Java程序设计》 第二周学习总结
    201521123001《Java程序设计》第11周学习总结
    201521123001《Java程序设计》第12周学习总结
    201521123001《Java程序设计》第11周学习总结
    201521123001《Java程序设计》第10周学习总结
    201521123001《Java程序设计》第9周学习总结
    201521123001《Java程序设计》第8周学习总结
    201521123001《Java程序设计》第7周学习总结
    201521123001《Java程序设计》第6周学习总结
    201521123001《Java程序设计》第5周学习总结
  • 原文地址:https://www.cnblogs.com/juechen/p/4721897.html
Copyright © 2011-2022 走看看