zoukankan      html  css  js  c++  java
  • Currency Exchange 分类: POJ 2015-07-14 16:20 10人阅读 评论(0) 收藏

    Currency Exchange
    Time Limit: 1000MS Memory Limit: 30000K
    Total Submissions: 22180 Accepted: 8015

    Description
    Several currency exchange points are working in our city. Let us suppose that each point specializes in two particular currencies and performs exchange operations only with these currencies. There can be several points specializing in the same pair of currencies. Each point has its own exchange rates, exchange rate of A to B is the quantity of B you get for 1A. Also each exchange point has some commission, the sum you have to pay for your exchange operation. Commission is always collected in source currency.
    For example, if you want to exchange 100 US Dollars into Russian Rubles at the exchange point, where the exchange rate is 29.75, and the commission is 0.39 you will get (100 - 0.39) * 29.75 = 2963.3975RUR.
    You surely know that there are N different currencies you can deal with in our city. Let us assign unique integer number from 1 to N to each currency. Then each exchange point can be described with 6 numbers: integer A and B - numbers of currencies it exchanges, and real RAB, CAB, RBA and CBA - exchange rates and commissions when exchanging A to B and B to A respectively.
    Nick has some money in currency S and wonders if he can somehow, after some exchange operations, increase his capital. Of course, he wants to have his money in currency S in the end. Help him to answer this difficult question. Nick must always have non-negative sum of money while making his operations.

    Input
    The first line of the input contains four numbers: N - the number of currencies, M - the number of exchange points, S - the number of currency Nick has and V - the quantity of currency units he has. The following M lines contain 6 numbers each - the description of the corresponding exchange point - in specified above order. Numbers are separated by one or more spaces. 1<=S<=N<=100, 1<=M<=100, V is real number, 0<=V<=103.
    For each point exchange rates and commissions are real, given with at most two digits after the decimal point, 10-2<=rate<=102, 0<=commission<=102.
    Let us call some sequence of the exchange operations simple if no exchange point is used more than once in this sequence. You may assume that ratio of the numeric values of the sums at the end and at the beginning of any simple sequence of the exchange operations will be less than 104.

    Output
    If Nick can increase his wealth, output YES, in other case output NO to the output file.

    Sample Input

    3 2 1 20.0
    1 2 1.00 1.00 1.00 1.00
    2 3 1.10 1.00 1.10 1.00

    Sample Output

    YES
    题意就是不同钱之间有着兑换比例和要交的费用
    问经过一系列的兑换后可不可是自己的钱增多

    #include <iostream>
    #include <cstdio>
    #include <cstring>
    #define exp 1e-9
    #define INF 0x3f3f3f3f
    
    using namespace std;
    
    const int Max=110;
    
    struct node
    {
        int v;
        int u;
        double rate;
        double com;
    } Edge[2*Max];
    double dis[Max];
    int n,m;
    int M;
    
    bool Bellman_Ford(int s,double v)
    {
        memset(dis,0,sizeof(dis));
        dis[s]=v;
        bool flag;
        while(dis[s]<=v+exp)
        {
            double ans;
            flag=true;
            for(int i=0; i<M; i++)
            {
                ans=(dis[Edge[i].u]-Edge[i].com)*Edge[i].rate;
                if(dis[Edge[i].v]+exp<ans)
                {
                    dis[Edge[i].v]=ans;
                    flag=false;
                }
            }
            if(flag)
            {
                if(dis[s]>v)
                {
                    return true;
                }
                else
                    return false;
            }
        }
        return true;
    }
    int main()
    {
        int s;
    
        double V;
        int u,v;
        double Ruv,Cuv,Rvu,Cvu;
        while(~scanf("%d %d %d %lf",&n,&m,&s,&V))
        {
            M=0;
            for(int i=0; i<m; i++)
            {
                scanf("%d %d %lf %lf %lf %lf",&u,&v,&Ruv,&Cuv,&Rvu,&Cvu);
                Edge[i].u=u;
                Edge[i].v=v;
                Edge[i].rate=Ruv;
                Edge[i].com=Cuv;
                M++;
                Edge[i+m].u=v;
                Edge[i+m].v=u;
                Edge[i+m].rate=Rvu;
                Edge[i+m].com=Cvu;
                M++;
            }
            if(Bellman_Ford(s,V))
            {
                cout<<"YES"<<endl;
            }
            else
            {
                cout<<"NO"<<endl;
            }
        }
        return 0;
    }
    

    版权声明:本文为博主原创文章,未经博主允许不得转载。

  • 相关阅读:
    【鬼脸原创】github搭建动态网站
    WebStorm配置(2016/11/18更新)
    前端学习入门
    css笔记
    c# 将文本中的数据快速导入到数据库(200万左右的数据量)
    3.数据库单多表查询
    2.数据库表的增删改
    1.数据库建表
    浏览器的兼容性测试
    python-路径处理path
  • 原文地址:https://www.cnblogs.com/juechen/p/4721963.html
Copyright © 2011-2022 走看看