zoukankan      html  css  js  c++  java
  • 第十二届浙江省大学生程序设计大赛-Demacia of the Ancients 分类: 比赛 2015-06-26 14:39 30人阅读 评论(0) 收藏

    Demacia of the Ancients
    Time Limit: 2 Seconds Memory Limit: 65536 KB

    There is a popular multiplayer online battle arena game called Demacia of the Ancients. There are lots of professional teams playing this game. A team will be approved as Level K if there are exact K team members whose match making ranking (MMR) is strictly greater than 6000.

    You are given a list of teams. Please calculate the level of each team.
    Input

    There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

    The first line contains an integer N (1 <= N <= 10) indicating the number of team members.

    The second line contains N integers representing the MMR of each team member. All MMRs are non-negative integers less than or equal to 9999.
    Output

    For each test case, output the level of the given team.
    Sample Input

    3
    5
    7986 6984 6645 6200 6150
    5
    7401 7377 6900 6000 4300
    3
    800 600 200

    Sample Output

    5
    3
    0

    #include <bits/stdc++.h>
    
    using namespace std;
    
    int main()
    {
        int t,n,i,sum;
        int a[100];
        scanf("%d",&t);
        while(t--)
        {
            scanf("%d",&n);
            sum=0;
            for(i=0; i<n; i++)
            {
                scanf("%d",&a[i]);
                if(a[i]>6000)
                    sum++;
    
    
            }
            cout<<sum<<endl;
        }
        return 0;
    }
    

    版权声明:本文为博主原创文章,未经博主允许不得转载。

  • 相关阅读:
    SQL 获取本年第几周
    SQL Server 数据类型
    (转)经典SQL查询语句大全
    mssql查询某个值存在某个表里的哪个字段的值里面
    SQL Server 数据库还原
    SQL Server 数据库备份
    【转】T-SQL 教程
    【原】C# decimal字符串转成整数
    Django基础篇(二)与mysql配合使用
    Django基础篇(一)
  • 原文地址:https://www.cnblogs.com/juechen/p/4721974.html
Copyright © 2011-2022 走看看