zoukankan      html  css  js  c++  java
  • 第十二届浙江省大学生程序设计大赛-Beauty of Array 分类: 比赛 2015-06-26 14:27 12人阅读 评论(0) 收藏

    Beauty of Array
    Time Limit: 2 Seconds Memory Limit: 65536 KB

    Edward has an array A with N integers. He defines the beauty of an array as the summation of all distinct integers in the array. Now Edward wants to know the summation of the beauty of all contiguous subarray of the array A.
    Input

    There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

    The first line contains an integer N (1 <= N <= 100000), which indicates the size of the array. The next line contains N positive integers separated by spaces. Every integer is no larger than 1000000.
    Output

    For each case, print the answer in one line.
    Sample Input

    3
    5
    1 2 3 4 5
    3
    2 3 3
    4
    2 3 3 2

    Sample Output

    105
    21
    38

    #include <iostream>
    #include <string>
    #include <stdio.h>
    #include<algorithm>
    #include<string.h>
    #include<cmath>
    #include<stack>
    #include<queue>
    
    using namespace std;
    
    const int MAX=1000000+100;
    
    int has[MAX];//记录在b位1的个数;
    long long sum,ans;
    
    int main()
    {
    
        int t,n,i,a;
    
        scanf("%d",&t);
    
        while(t--)
        {
    
            scanf("%d",&n);
    
            sum=0;
    
            ans=0;
    
            memset(has,0,sizeof(has));
    
            for(i=1;i<=n;i++)
            {
                scanf("%d",&a);
    
                ans+=(i-has[a])*a;
    
                sum+=ans;
    
                has[a]=i;
    
            }
    
            cout<<sum<<endl;
        }
    
        return 0;
    }

    版权声明:本文为博主原创文章,未经博主允许不得转载。

  • 相关阅读:
    C#及时释放代码
    软件本质是什么?
    WCF学习
    android 更新ui
    ijkplayer视频播放
    androidstudio集成ijkplayer教程
    IJKPlayer问题集锦之不定时更新
    github上十二款最著名的Android播放器开源项目
    让ubuntu支持GBK编码AAAAA
    adb命令--之查看进程及Kill进程
  • 原文地址:https://www.cnblogs.com/juechen/p/4721978.html
Copyright © 2011-2022 走看看