zoukankan      html  css  js  c++  java
  • Design T-Shirt 分类: HDU 2015-06-26 11:58 7人阅读 评论(0) 收藏

    Design T-Shirt

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 6744    Accepted Submission(s): 3167


    Problem Description
    Soon after he decided to design a T-shirt for our Algorithm Board on Free-City BBS, XKA found that he was trapped by all kinds of suggestions from everyone on the board. It is indeed a mission-impossible to have everybody perfectly satisfied. So he took a poll to collect people's opinions. Here are what he obtained: N people voted for M design elements (such as the ACM-ICPC logo, big names in computer science, well-known graphs, etc.). Everyone assigned each element a number of satisfaction. However, XKA can only put K (<=M) elements into his design. He needs you to pick for him the K elements such that the total number of satisfaction is maximized.
     

    Input
    The input consists of multiple test cases. For each case, the first line contains three positive integers N, M and K where N is the number of people, M is the number of design elements, and K is the number of elements XKA will put into his design. Then N lines follow, each contains M numbers. The j-th number in the i-th line represents the i-th person's satisfaction on the j-th element.
     

    Output
    For each test case, print in one line the indices of the K elements you would suggest XKA to take into consideration so that the total number of satisfaction is maximized. If there are more than one solutions, you must output the one with minimal indices. The indices start from 1 and must be printed in non-increasing order. There must be exactly one space between two adjacent indices, and no extra space at the end of the line.
     

    Sample Input
    3 6 4 2 2.5 5 1 3 4 5 1 3.5 2 2 2 1 1 1 1 1 10 3 3 2 1 2 3 2 3 1 3 1 2
     

    Sample Output
    6 5 3 1 2 1
    #include <iostream>
    #include <cstring>
    #include <cstdio>
    #include <cmath>
    #include <string>
    #include <stack>
    #include <algorithm>
    using namespace std;
    
    const int Max=1100000;
    
    struct ELE
    {
        int num;
        double  sum;
    } E[1100];
    int a[1100];
    bool cmp1(ELE a,ELE b)
    {
        if(a.sum>b.sum||(a.sum==b.sum&&a.num<b.num))
            return true;
        return false;
    }
    bool cmp2(int a,int b)
    {
        return a>b;
    }
    int main()
    {
        int n,m,k;
        double data;
        while(~scanf("%d %d %d",&n,&m,&k))
        {
            for(int i=0; i<n; i++)
            {
                for(int j=0; j<m; j++)
                {
                    scanf("%lf",&data);
                    if(i)
                    {
                        E[j].sum+=data;
                    }
                    else
                    {
                        E[j].num=j+1;
                        E[j].sum=data;
                    }
                }
            }
            sort(E,E+m,cmp1);
            for(int i=0;i<k;i++)
            {
                a[i]=E[i].num;
            }
            sort(a,a+k,cmp2);
            for(int i=0;i<k;i++)
            {
                if(i)
                    cout<<" ";
                cout<<a[i];
            }
            cout<<endl;
        }
        return 0;
    }
    


     

    版权声明:本文为博主原创文章,未经博主允许不得转载。

  • 相关阅读:
    linux命令(8):du命令
    linux命令(7):ipcs/ipcrm命令
    linux命令(6):tar命令
    linux命令(5):netstat命令
    linux命令(4):vmstat命令
    linux命令(3):rpm命令
    linux命令(2):grep命令
    linux命令(1):sed命令
    链表中倒数第k个节点
    链表刷题总结
  • 原文地址:https://www.cnblogs.com/juechen/p/4721981.html
Copyright © 2011-2022 走看看