zoukankan      html  css  js  c++  java
  • Train Problem I 分类: HDU 2015-06-26 11:27 10人阅读 评论(0) 收藏

    Train Problem I

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 25029    Accepted Submission(s): 9445


    Problem Description
    As the new term comes, the Ignatius Train Station is very busy nowadays. A lot of student want to get back to school by train(because the trains in the Ignatius Train Station is the fastest all over the world ^v^). But here comes a problem, there is only one railway where all the trains stop. So all the trains come in from one side and get out from the other side. For this problem, if train A gets into the railway first, and then train B gets into the railway before train A leaves, train A can't leave until train B leaves. The pictures below figure out the problem. Now the problem for you is, there are at most 9 trains in the station, all the trains has an ID(numbered from 1 to n), the trains get into the railway in an order O1, your task is to determine whether the trains can get out in an order O2.
     

    Input
    The input contains several test cases. Each test case consists of an integer, the number of trains, and two strings, the order of the trains come in:O1, and the order of the trains leave:O2. The input is terminated by the end of file. More details in the Sample Input.
     

    Output
    The output contains a string "No." if you can't exchange O2 to O1, or you should output a line contains "Yes.", and then output your way in exchanging the order(you should output "in" for a train getting into the railway, and "out" for a train getting out of the railway). Print a line contains "FINISH" after each test case. More details in the Sample Output.
     

    Sample Input
    3 123 321 3 123 312
     

    Sample Output
    Yes. in in in out out out FINISH No. FINISH
    /*
    模拟题,利用栈,最先出栈的在最前,不断的进栈,同时比较栈头与出栈的元素是不是相同的,
    如果相同则出栈,最后如果还有剩余元素,则不符合
    */
    #include <iostream>
    #include <cstring>
    #include <cstdio>
    #include <cmath>
    #include <string>
    #include <stack>
    
    using namespace std;
    
    const int Max=1100000;
    
    char IN[15];
    char OUT[15];
    string str[110];
    int main()
    {
        int n;
        while(~scanf("%d %s %s",&n,IN,OUT))
        {
            int top=0;
            stack<char>a;
            int i=0,j=0;
            while(i<n&&j<n)
            {
                if(a.empty()||a.top()!=OUT[j])
                {
                    a.push(IN[i++]);
                    str[top++]="in";
                }
                else
                {
                    a.pop();
                    j++;
                    str[top++]="out";
                }
            }
            while(j<n&&!a.empty()&&a.top()==OUT[j])
            {
                a.pop();
                j++;
                str[top++]="out";
            }
            if(a.empty())//判断是否符合
            {
                cout<<"Yes."<<endl;
                for(int i=0;i<top;i++)
                {
                    cout<<str[i]<<endl;
                }
                cout<<"FINISH"<<endl;
            }
            else
            {
                cout<<"No."<<endl<<"FINISH"<<endl;
            }
        }
    
        return 0;
    }
    

     

    版权声明:本文为博主原创文章,未经博主允许不得转载。

  • 相关阅读:
    SDN2017 第四次作业
    SDN2017 第三次实验作业
    软件工程实践2017 个人作业——软件工程实践总结作业
    sdn2017 第三次作业
    Golang 探索对Goroutine的控制方法
    SDN2017 第二次实验作业
    SDN2017 第二次作业
    Redis在游戏服务器中的应用
    手机游戏开发
    手机游戏开发
  • 原文地址:https://www.cnblogs.com/juechen/p/4721982.html
Copyright © 2011-2022 走看看