zoukankan      html  css  js  c++  java
  • Let the Balloon Rise 分类: HDU 2015-06-19 19:11 7人阅读 评论(0) 收藏

    Let the Balloon Rise

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 87647    Accepted Submission(s): 33130


    Problem Description
    Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

    This year, they decide to leave this lovely job to you.
     

    Input
    Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

    A test case with N = 0 terminates the input and this test case is not to be processed.
     

    Output
    For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.
     

    Sample Input
    5 green red blue red red 3 pink orange pink 0
     

    Sample Output
    red pink 想了好久,决定用链表了
    #include <iostream>
    using namespace std;
    const int Max=1100;
    struct node
    {
        string s;
        int num;
        node *next;
    
    };
    int main()
    {
        int n;
        string str;
        while(cin>>n,n)
        {
            node *head,*p,*q;
            head=new node;
            head->next=NULL;
            for(int i=0; i<n; i++)
            {
                cin>>str;
                q=head;
                p=head->next;
                while(p)
                {
                    if(p->s==str)
                    {
                        p->num++;
                        break;
                    }
                    p=p->next;
                    q=q->next;
                }
                if(!p)
                {
                    p=new node;
                    p->s=str;
                    p->num=1;
                    p->next=NULL;
                    q->next=p;
                }
            }
            p=head->next;
            q=head->next;
            while(p)
            {
                if(p->num>q->num)
                {
                    q=p;
                }
                p=p->next;
            }
            cout<<q->s<<endl;
    
        }
        return 0;
    }
    
    


    版权声明:本文为博主原创文章,未经博主允许不得转载。

  • 相关阅读:
    web.xml中 error-page的正确用法
    5.项目数据库设计--人事管理系统
    mod_jk是Apache服务器的一个可插入模块
    jBox使用方法
    ApacheHttpServer出现启动报错:the requested operation has failed解决办法
    ApacheHttpServer修改httpd.conf配置文件
    redis client protocol 分解
    Andorid Async-HttpClient阅览
    HDU-2857-Mirror and Light(计算几何)
    xcode armv6 armv7 armv7s arm64
  • 原文地址:https://www.cnblogs.com/juechen/p/4722009.html
Copyright © 2011-2022 走看看