zoukankan      html  css  js  c++  java
  • HDU1950-Bridging signals-最长上升子序列

    Description

    'Oh no, they've done it again', cries the chief designer at the Waferland chip factory. Once more the routing designers have screwed up completely, making the signals on the chip connecting the ports of two functional blocks cross each other all over the place. At this late stage of the process, it is too 
    expensive to redo the routing. Instead, the engineers have to bridge the signals, using the third dimension, so that no two signals cross. However, bridging is a complicated operation, and thus it is desirable to bridge as few signals as possible. The call for a computer program that finds the maximum number of signals which may be connected on the silicon surface without rossing each other, is imminent. Bearing in mind that there may be housands of signal ports at the boundary of a functional block, the problem asks quite a lot of the programmer. Are you up to the task?

     

    Figure 1. To the left: The two blocks' ports and their signal mapping (4,2,6,3,1,5). To the right: At most three signals may be routed on the silicon surface without crossing each other. The dashed signals must be bridged. 

    A typical situation is schematically depicted in figure 1. The ports of the two functional blocks are numbered from 1 to p, from top to bottom. The signal mapping is described by a permutation of the numbers 1 to p in the form of a list of p unique numbers in the range 1 to p, in which the i:th number pecifies which port on the right side should be connected to the i:th port on the left side. 
    Two signals cross if and only if the straight lines connecting the two ports of each pair do.

     

    Input

    On the first line of the input, there is a single positive integer n, telling the number of test scenarios to follow. Each test scenario begins with a line containing a single positive integer p<40000, the number of ports on the two functional blocks. Then follow p lines, describing the signal mapping: On the i:th line is the port number of the block on the right side which should be connected to the i:th port of the block on the left side.
     

    Output

    For each test scenario, output one line containing the maximum number of signals which may be routed on the silicon surface without crossing each other.
     

    Sample Input

    4 6
    4 2 6 3 1 5 10 
    2 3 4 5 6 7 8 9 10 1 8 
    8 7 6 5 4 3 2 1 9 
    5 8 9 2 3 1 7 4 6
     

    Sample Output

    3 9 1 4
     
    题目本质::求最长上升子序列(这里没有反复数字)。

    我们有两种思路求能够參考shuoj上的D序列的题目。这里给出题目的题解链接::shuojD序列

    主要是两种思路::(1)lower_bound(2)二分法,假设认为代码不易理解能够点上面的链接

    两种方法的思路是一样的。

    将数组A中子序列长度为 i 的最小值存放在数组S中。我们以3 2 4 6  5 7 3 为例进行演示行为遍历,列为数组S。变化的地方已经标出来,有助于理解。

    在这里a[ i ] > s[ j ]&&a[i]<=s[ j + 1 ]就应该把a[ i ]放在s[ j+1 ]的位置。

    所以关键就是找出 j 就知道把a[ i ]放在哪了。

    上面的两种方法就是用来寻找 j的 。

    (在这里lower_bound直接返回 j + 1 ) 

    我们能够发现s数组中的值必定是有序递增的。这也是能够利用二分法的一个必要条件。

    演示
    0 1 2 3 4
    1 3      
    2 2      
    3 2 4    
    4 2 4 6  
    5 2 4 5  
    6 2 4 5 7
    7 2 3 5 7
             

    这里给出另外一种方法代码::

    #include <iostream>
    #include<cstring>
    #include <algorithm>
    #define INF 0x3f3f3f3f
    using namespace std;
    const int N = 1e5 + 5;
    int s[N];
    int n,p,a[N];
    int len;
    int main()
    {
    	cin>>n;
    	while(n--){
    		cin>>p;
    		memset(s,0,sizeof(s));
    		for(int i = 0;i<p;i++)cin>>a[i];
    		s[1] = a[0];len = 1;//长度从1開始
    		for(int i = 1;i<p;i++){
    
    			int t = a[i];
    			if(t>s[len])s[++len] = a[i];
    			else{
    		/*************/int l = 1,r = len,mid;//这里的二分法採用了左闭右闭的思路
                   <span style="white-space:pre">			</span>int ans = 0;
    				while(l<=r)
    				{
    					mid = (l+r)/2;
    					if(s[mid]<t)
                            {l = mid +1;ans = max(ans,mid);}//ans即为思路中的j,j必定为s数组中小于t的最大的数
    					else r = mid-1;
    				}
    				s[ans+1] = t;/******************/
    			}
    		}
    		//for(int i = 1;i<p;i++){cout<<s[i];}//有必要能够打开看看s中存的是什么值
    		cout<<len<<endl;
    	}
    	return 0;
    }
    假设代码不易理解请点击链接,链接为::shuoj—D序列

    第一种的代码仅仅要将两个/**************/之间的代码换为

    int p = lower_bound(s+1,s+len+1,t)-s;
    s[p] = t;
    就能够了。
  • 相关阅读:
    设计模式大赛 -- 大话设计模式
    访问者模式 -- 大话设计模式
    puts的用处
    scanf的使用
    iOS,手势识别简单使用
    iOS,多媒体,地图相关
    iOS,文本输入,键盘相关
    iOS,XMPP本地环境搭建和框架使用
    iOS,自动布局autoresizing和auto layout,VFL语言
    iOS,图片处理
  • 原文地址:https://www.cnblogs.com/jzssuanfa/p/6747080.html
Copyright © 2011-2022 走看看