zoukankan      html  css  js  c++  java
  • HDUJ 2052 Picture 模拟

    Picture

    Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 15932    Accepted Submission(s): 8240


    Problem Description
    Give you the width and height of the rectangle,darw it.
     

    Input
    Input contains a number of test cases.For each case ,there are two numbers n and m (0 < n,m < 75)indicate the width and height of the rectangle.Iuput ends of EOF.
     

    Output
    For each case,you should draw a rectangle with the width and height giving in the input.
    after each case, you should a blank line.
     

    Sample Input
    3 2
     

    Sample Output
    +---+ | | | | +---+



    #include<iostream>
    #include<cstring>
    using namespace std;
    
    int main()
    {
    	int n,m;
    	while(cin>>n>>m)
    	{
    		char str[85][85];
    		memset(str,0,sizeof(str));
    		int i,j;
    		for(i=0;i<=m+1;i++)
    		{
    			for(j=0;j<=n+1;j++)
    			{
    				if(i==0 || i==m+1)
    					str[i][j]='-';
    				else
    					str[i][j]=' ';
    				if(j==0 || j==n+1)
    					str[i][j]='|';
    			}
    		}
    
    		str[0][0]=str[0][n+1]=str[m+1][0]=str[m+1][n+1]='+';
    		for(i=0;i<=m+1;i++)
    		{
    			for(j=0;j<=n+1;j++)
    				cout<<str[i][j];
    			cout<<endl;
    		}
    		cout<<endl;
    	}
    
    	return 0;
    }


  • 相关阅读:
    GO开发[一]:golang语言初探
    Python带参数的装饰器
    Python函数篇
    19. logging模块
    18. json模块
    17. os模块
    16. sys模块
    15. random模块
    14. 模块-time模块
    29. java面向对象项目
  • 原文地址:https://www.cnblogs.com/jzssuanfa/p/6789433.html
Copyright © 2011-2022 走看看