zoukankan      html  css  js  c++  java
  • POJ 1581 A Contesting Decision

    A Contesting Decision
    Time Limit: 1000MS   Memory Limit: 10000K
    Total Submissions: 2512   Accepted: 1780

    Description

    Judging a programming contest is hard work, with demanding contestants, tedious decisions,and monotonous work. Not to mention the nutritional problems of spending 12 hours with only donuts, pizza, and soda for food. Still, it can be a lot of fun. 
    Software that automates the judging process is a great help, but the notorious unreliability of some contest software makes people wish that something better were available. You are part of a group trying to develop better, open source, contest management software, based on the principle of modular design. 
    Your component is to be used for calculating the scores of programming contest teams and determining a winner. You will be given the results from several teams and must determine the winner. 
    Scoring 
    There are two components to a team's score. The first is the number of problems solved. The second is penalty points, which reflects the amount of time and incorrect submissions made before the problem is solved. For each problem solved correctly, penalty points are charged equal to the time at which the problem was solved plus 20 minutes for each incorrect submission. No penalty points are added for problems that are never solved. 
    So if a team solved problem one on their second submission at twenty minutes, they are charged 40 penalty points. If they submit problem 2 three times, but do not solve it, they are charged no penalty points. If they submit problem 3 once and solve it at 120 minutes, they are charged 120 penalty points. Their total score is two problems solved with 160 penalty points. 
    The winner is the team that solves the most problems. If teams tie for solving the most problems,then the winner is the team with the fewest penalty points.

    Input

    For the programming contest your program is judging, there are four problems. You are guaranteed that the input will not result in a tie between teams after counting penalty points. 
    Line 1 < nTeams > 
    Line 2 - n+1 < Name > < p1Sub > < p1Time > < p2Sub > < p2Time > ... < p4Time > 
    The first element on the line is the team name, which contains no whitespace.Following that, for each of the four problems, is the number of times the team submitted a run for that problem and the time at which it was solved correctly (both integers). If a team did not solve a problem, the time will be zero. The number of submissions will be at least one if the problem was solved.

    Output

    The output consists of a single line listing the name of the team that won, the number of problems they solved, and their penalty points.

    Sample Input

    4
    Stars 2 20 5 0 4 190 3 220
    Rockets 5 180 1 0 2 0 3 100
    Penguins 1 15 3 120 1 300 4 0
    Marsupials 9 0 3 100 2 220 3 80

    Sample Output

    Penguins 3 475

    Source



    题目大意:

    评判比赛胜利。依次输入四道题的提交数和罚时。罚时等于该问题被解出的时间加上每次错误提交错误的20分钟罚时。

    优胜队是提交正确最多的人。假设两队以上在解题数上打成平手,那么罚时少的人获胜。


    用结构体数组非常easy。。。

    #include <iostream>
    #include <cstring>
    #include <string>
    #define maxn 30
    #define maxs 1000
    using namespace std;
    struct student
    {
        char name[maxn];
        int subi[maxn];
        int timei[maxn];
        int num,time;
    }stu[maxs];
    
    int main()
    {
        int n;
        cin>>n;
    
        memset(stu,0,sizeof(0));
        int i;
        for(i=1;i<=n;i++)
        {
            cin>>stu[i].name;
            int j;
            for(j=1;j<=4;j++)
            {
                cin>>stu[i].subi[j]>>stu[i].timei[j];
                stu[i].num=stu[i].time=0;
            }
    
            for(j=1;j<=4;j++)
            {
                if(stu[i].timei[j]!=0)
                {
                    stu[i].num+=1;
                    stu[i].time+=stu[i].timei[j]+(stu[i].subi[j]-1)*20;
                }
            }
        }
        /*for(i=1;i<=n;i++)
        {
            cout<<stu[i].name<<" "<<stu[i].num<<" "<<stu[i].time<<endl;
        }*/
        char winname[maxn];
        int winnum=-1;
        int wintime=1000000000;
    
        for(i=1;i<=n;i++)
        {
            if(stu[i].num>=winnum&&stu[i].time<wintime)
            {
                winnum=stu[i].num;
                wintime=stu[i].time;
                strcpy(winname,stu[i].name);
            }
        }
    
        cout<<winname<<" "<<winnum<<" "<<wintime<<endl;
        return 0;
    }
    /*
    4
    Stars 2 20 5 0 4 190 3 220
    Rockets 5 180 1 0 2 0 3 100
    Penguins 1 15 3 120 1 300 4 0
    Marsupials 9 0 3 100 2 220 3 80
    */


  • 相关阅读:
    Servlet设置Cookie无效
    IOS即时通讯XMPP搭建openfire服务器
    IOS之富文本编辑
    unittest单元测试框架总结
    杀死future处理的阻塞线程
    APP的UI设计原则
    如何降低一个程序的耦合性
    Hyperopt中文文档导读
    Hyperopt中文文档导读
    AdaBoost算法特性
  • 原文地址:https://www.cnblogs.com/jzssuanfa/p/7019984.html
Copyright © 2011-2022 走看看