zoukankan      html  css  js  c++  java
  • HDU 4772 Zhuge Liang's Password (简单模拟题)

    题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=4772


    题面:

    Zhuge Liang's Password

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 1404    Accepted Submission(s): 926


    Problem Description
      In the ancient three kingdom period, Zhuge Liang was the most famous and smart military leader. His enemy was Sima Yi, the military leader of Kingdom Wei. Sima Yi always looked stupid when fighting against Zhuge Liang. But it was Sima Yi who laughed to the end.
      Zhuge Liang had led his army across the mountain Qi to attack Kingdom Wei for six times, which all failed. Because of the long journey, the food supply was a big problem. Zhuge Liang invented a kind of bull-like or horse-like robot called "Wooden Bull & Floating Horse"(in abbreviation, WBFH) to carry food for the army. Every WBFH had a password lock. A WBFH would move if and only if the soldier entered the password. Zhuge Liang was always worrying about everything and always did trivial things by himself. Since Ma Su lost Jieting and was killed by him, he didn't trust anyone's IQ any more. He thought the soldiers might forget the password of WBFHs. So he made two password cards for each WBFH. If the soldier operating a WBFH forgot the password or got killed, the password still could be regained by those two password cards.
      Once, Sima Yi defeated Zhuge Liang again, and got many WBFHs in the battle field. But he didn't know the passwords. Ma Su's son betrayed Zhuge Liang and came to Sima Yi. He told Sima Yi the way to figure out the password by two cards.He said to Sima Yi:
      "A password card is a square grid consisting of N×N cells.In each cell,there is a number. Two password cards are of the same size. If you overlap them, you get two numbers in each cell. Those two numbers in a cell may be the same or not the same. You can turn a card by 0 degree, 90 degrees, 180 degrees, or 270 degrees, and then overlap it on another. But flipping is not allowed. The maximum amount of cells which contains two equal numbers after overlapping, is the password. Please note that the two cards must be totally overlapped. You can't only overlap a part of them."
      Now you should find a way to figure out the password for each WBFH as quickly as possible.
     

    Input
      There are several test cases.
      In each test case:
      The first line contains a integer N, meaning that the password card is a N×N grid(0<N<=30).
      Then a N×N matrix follows ,describing a password card. Each element is an integer in a cell.
      Then another N×N matrix follows, describing another password card.
      Those integers are all no less than 0 and less than 300.
      The input ends with N = 0
     

    Output
      For each test case, print the password.
     

    Sample Input
    2 1 2 3 4 5 6 7 8 2 10 20 30 13 90 10 13 21 0
     

    Sample Output
    0 2
     

    Source
     

    解题:
        简单模拟下旋转就好。



    代码:

    #include <iostream>
    using namespace std;
    int m1[31][31],m2[31][31],m3[31][31],m4[31][31],m5[31][31];
    int main()
    {
    	int ans,cnt1,cnt2,cnt3,cnt4;
    	int n;
    	while(cin>>n&&n)
    	{
    		cnt1=cnt2=cnt3=cnt4=0;
    		for(int i=1;i<=n;i++)
    		{
    			for(int j=1;j<=n;j++)
    				cin>>m1[i][j];
    		}
    		for(int i=1;i<=n;i++)
    		{
    			for(int j=1;j<=n;j++)
    				cin>>m2[i][j];
    		}
    		for(int i=1;i<=n;i++)
    		{
    			for(int j=1;j<=n;j++)
    				m3[j][i]=m2[i][n-j+1];
    		}
    		for(int i=1;i<=n;i++)
    		{
    			for(int j=1;j<=n;j++)
    				m4[j][i]=m3[i][n-j+1];
    		}
    		for(int i=1;i<=n;i++)
    		{
    			for(int j=1;j<=n;j++)
    				m5[j][i]=m4[i][n-j+1];
    		}
    		for(int i=1;i<=n;i++)
    		{
    			for(int j=1;j<=n;j++)
    			{
    				if(m2[i][j]==m1[i][j])cnt1++;
                    if(m3[i][j]==m1[i][j])cnt2++;
                    if(m4[i][j]==m1[i][j])cnt3++;
                    if(m5[i][j]==m1[i][j])cnt4++;
    			}
    		}
    		ans=cnt1;
    		if(cnt2>ans)ans=cnt2;
    		if(cnt3>ans)ans=cnt3;
    		if(cnt4>ans)ans=cnt4;
    		cout<<ans<<endl;
    	}
    	return 0;
    }



  • 相关阅读:
    Wyn Enterprise报表动态参数的实现
    全功能 Visual Studio 组件集 ComponentOne 2018V2发布,提供轻量级的 .NET BI 仪表板
    葡萄城SpreadJS表格控件荣获“2018年度优秀软件产品”称号
    中国电建:ComponentOne+Spread突破行业桎梏,推动数据产业“智能化”变革
    葡萄城活字格 Web 应用生成平台荣获软博会十佳优秀产品
    石油与天然气行业中数据报表分析
    从容 IT 人生路,开发工具伴我行——“葡萄城 30 周年”征文
    用WijmoJS玩转您的Web应用 —— Angular6
    对抗海量表格数据,【华为2012实验室】没有选择复仇者联盟
    投票最喜欢报表模板,赢取复联3正版玩偶
  • 原文地址:https://www.cnblogs.com/jzssuanfa/p/7299080.html
Copyright © 2011-2022 走看看