zoukankan      html  css  js  c++  java
  • [USACO16OPEN]248

    题目描述

    Bessie likes downloading games to play on her cell phone, even though she doesfind the small touch screen rather cumbersome to use with her large hooves.

    She is particularly intrigued by the current game she is playing.The game starts with a sequence of NNpositive integers (2 leq Nleq 2482N248), each in the range 1 ldots 40140. In one move, Bessie cantake two adjacent numbers with equal values and replace them a singlenumber of value one greater (e.g., she might replace two adjacent 7swith an 8). The goal is to maximize the value of the largest numberpresent in the sequence at the end of the game. Please help Bessiescore as highly as possible!

    给定一个1*n的地图,在里面玩2048,每次可以合并相邻两个(数值范围1-40),问最大能合出多少。注意合并后的数值并非加倍而是+1,例如2与2合并后的数值为3。

    输入输出格式

    输入格式:

    The first line of input contains N, and the next N lines give the sequence

    of Nnumbers at the start of the game.

    输出格式:

    Please output the largest integer Bessie can generate.

    输入输出样例

    输入样例#1: 
    4
    1
    1
    1
    2
    输出样例#1: 
    3

    说明

    In this example shown here, Bessie first merges the second and third 1s to

    obtain the sequence 1 2 2, and then she merges the 2s into a 3. Note that it is

    not optimal to join the first two 1s.

    分析:

    连加强版262144都做过了还害怕什么呢???

    所以详细分析看:262144

    CODE:

    #include <cstdio>
    #include<iostream>
    using namespace std;
    int n,ans;
    int f[45][282144];
    int main(){
        cin>>n;
        for (int i=1;i<=n;++i){
            int x;
            cin>>x;
            f[x][i]=i+1;
        }
        for (int i=2;i<=45;i++){
            for (int j=1;j<=n;j++){
                if (!f[i][j]) f[i][j]=f[i-1][f[i-1][j]];
                if (f[i][j]) ans=i;
            }
        }
        cout<<ans<<endl;
        //system("pause");
        return 0;
    }
  • 相关阅读:
    C#逻辑运算符
    C#:采用TuesPechkin生成Pdf
    C# 发布时出现:在与 SQL Server 建立连接时出现与网络相关的或特定于实例的错误
    C# winform在窗体中动态添加按钮
    C# winform滚动字幕效果
    C# Winform操作注册表实现窗体的定位记忆功能
    C#提取类型的所有方法和参数
    .NET FCL(框架类库)名称空间说明
    .NET框架通用语言运行时(CLR)的执行模型
    坚持学习,高效率才能更有水平
  • 原文地址:https://www.cnblogs.com/kanchuang/p/11163173.html
Copyright © 2011-2022 走看看