zoukankan      html  css  js  c++  java
  • Windows Message Queue

    Message queue is the basic fundamental of windows system. For each process, the system maintains a message queue. If something happens to this process, such as mouse click, text change, the system will add a message to the queue. Meanwhile, the process will do a loop for getting message from the queue according to the priority value if it is not empty. Note that the less priority value means the higher priority. In this problem, you are asked to simulate the message queue for putting messages to and getting message from the message queue.

    Input

    There's only one test case in the input. Each line is a command, "GET" or "PUT", which means getting message or putting message. If the command is "PUT", there're one string means the message name and two integer means the parameter and priority followed by. There will be at most 60000 command. Note that one message can appear twice or more and if two messages have the same priority, the one comes first will be processed first.(i.e., FIFO for the same priority.) Process to the end-of-file.

    <b< dd="">

    Output

    For each "GET" command, output the command getting from the message queue with the name and parameter in one line. If there's no message in the queue, output "EMPTY QUEUE!". There's no output for "PUT" command.

    <b< dd="">

    Sample Input

    GET
    PUT msg1 10 5
    PUT msg2 10 4
    GET
    GET
    GET
    

    <b< dd="">

    Sample Output

    EMPTY QUEUE!
    msg2 10
    msg1 10
    EMPTY QUEUE!
    
    #include<iostream>
    #include<string >
    #include<queue>
    #include<map>
    using namespace std;
    struct kang
    {
        char k[220];
        int a, b, c;
    };
    map<int, int> ko;
    bool operator < (const kang & a, const kang & b)
    {
        if (a.b != b.b)
            return a.b > b.b;
        return  a.c > b.c;
    }
    int main()
    {
        priority_queue<kang> k;
        char str[10];
        while (cin >> str)
        {
            if (str[0] == 'G')
            {
                if (k.empty())
                    cout << "EMPTY QUEUE!" << endl;
                else
                {
                    kang kg;
                    kg = k.top();
                    k.pop();
                    cout << kg.k <<" "<< kg.a << endl;
                }
            }
            else
            {
                kang kg;
                cin >> kg.k >> kg.a >> kg.b;
                kg.c = ko[kg.b]++;
                k.push(kg);
            }
        }
        return 0;
    }
  • 相关阅读:
    pip 的简单安装与基本使用
    macOS(OS X)安装与配置 Homebrew
    命令行媒体处理工具 FFmpeg
    修正 FreeBSD 字体锯齿问题
    在 Linux 环境直接复移动硬盘上的 GRUB
    命令行视频下载工具 youget 和 youtubedl
    20不努力,30做助理(转载)
    树、森林和二叉树的转换
    百度地图和solr展示资源和附近等功能的实现 二
    加密Web项目中数据库配置文件中的密码
  • 原文地址:https://www.cnblogs.com/kangdong/p/8454913.html
Copyright © 2011-2022 走看看