zoukankan      html  css  js  c++  java
  • 2018 ICPC焦作网络赛 K Transport Ship(多重背包二进制优化)

    There are different kinds of transport ships on the port. The ith kind of ship can carry the weight of V[i]V[i] and the number of the ith kind of ship is 2c[i]-12^{C[i]} - 12. How many different schemes there are if you want to use these ships to transport cargo with a total weight of S?

    It is required that each ship must be full-filled. Two schemes are considered to be the same if they use the same kinds of ships and the same number for each kind.

    Input

    The first line contains an integer T(1≤T≤20), which is the number of test cases.

    For each test case:

    The first line contains two integers: N(1≤N≤20)Q(1≤Q≤10000), representing the number of kinds of ships and the number of queries.

    For the next lines, each line contains two integers: V[i](1≤V[i]≤20), C[i](1C[i]≤20), representing the weight the ith kind of ship can carry, and the number of the ith kind of ship is 2c[i]-1.

    For the next Q lines, each line contains a single integer: S(1≤S≤10000), representing the queried weight.

    Output

    For each query, output one line containing a single integer which represents the number of schemes for arranging ships. Since the answer may be very large, output the answer modulo 10000000071000000007.

    样例输入

    1
    1 2
    2 1
    1
    2

    样例输出

    0
    1

    题意:

    有N种船只,每种船只的载货量为V[i](以下代码用w[i]表示),每种船只的数量为2^c[i]-1。接下来有Q次询问,每次问有多少种载货方式可以填满容量S。

    思路:

    如果用裸的01背包的话时间复杂度是O(N*2^c[i]*10000),显然会超时,但是我们可以把每一种船合并,比如船只有2n-1艘的话,就拆成20+21+22+...+2n-1,1~2n-1之中的任意一个数都可以由拆分出来的数组成,将所有合并后的结果进行一次多重背包即可。

    #include<bits/stdc++.h>
    using namespace std;
    const int MAX=1e4;
    const int mod=1e9+7;
    typedef long long ll;
    int w[25],c[25];
    ll dp[MAX+5];
    int main()
    {
        int n,i,T,q,s,j,k;
        ios::sync_with_stdio(false);
        cin>>T;
        while(T--)
        {
            cin>>n>>q;
            for(i=1;i<=n;i++)
                cin>>w[i]>>c[i];
            memset(dp,0,sizeof(dp));
            dp[0]=1;
            for(i=1;i<=n;i++)       //共n种船
            {
                int t=1;
                for(j=1;j<=c[i];j++)//每种船有2^c[i]-1只
                {
                    for(k=MAX;k>=t*w[i];k--)
                        dp[k]=(dp[k]+dp[k-t*w[i]])%mod;
                    t<<=1;
                }
            }
            while(q--)
            {
                cin>>s;
                cout<<dp[s]<<endl;
            }
        }
        return 0;
    }
  • 相关阅读:
    work_27_一次springBoot+orcal+Mabits PageHele的使用
    work_26_swagger2整合springBoot和使用
    work_25_docker--RabbitMq消息队列
    work_24_MYSQL从create table... 到分库分表
    work_23_常用的工具类
    work_22_MySQL分库分表的初识
    work_21_AtomicInteger API
    work_20_stream的使用
    MySQL 基础语句的练习2
    MySQL 基础语句的练习
  • 原文地址:https://www.cnblogs.com/kannyi/p/9756877.html
Copyright © 2011-2022 走看看