zoukankan      html  css  js  c++  java
  • HDU1262 寻找素数对

    Problem Description
    哥德巴赫猜想大家都知道一点吧.我们现在不是想证明这个结论,而是想在程序语言内部能够表示的数集中,任意取出一个偶数,来寻找两个素数,使得其和等于该偶数.
    做好了这件实事,就能说明这个猜想是成立的.
    由于可以有不同的素数对来表示同一个偶数,所以专门要求所寻找的素数对是两个值最相近的.
     
    Input
    输入中是一些偶整数M(5<M<=10000).
     
    Output
    对于每个偶数,输出两个彼此最接近的素数,其和等于该偶数.
     
    Sample Input
    20 30 40
     
    Sample Output
    7 13
    13 17
    17 23
    Source
     
    import java.util.Scanner;
    
    public class HDU1262 {
    
        public static void main(String[] args) {
            // TODO Auto-generated method stub
            Scanner input = new Scanner(System.in);
            
            int count =0;
            int num = 10000;
            boolean[] bl = new boolean[100000000];
            int[]  primeList = new int[num];
            for(int i =2;i < num;i++){
                if(!bl[i]){
                    primeList[count++] = i;
                }
                for(int j =0;j < count;j++){
                    if(i*primeList[j] > num){
                        break;
                    }
                    bl[i*primeList[j]] = true;
                    if(i%primeList[j]==0){
                        break;
                    }
                }
            }
            
            for(;;){
                int p = input.nextInt();
                for(int i = p/2-1;i >= 2;i++){
                    if(!bl[i] && !bl[p-i]){
                        System.out.println((p-i) + " " + i);
                        break;
                    }
                }
                
            }
            
        }
    
    }
    View Code
  • 相关阅读:
    Python3 循环语句
    Python3 条件控制
    Python3 字典
    Python3 元组
    Python的字符串函数
    2019/10/24
    JS-字符串方法总结
    maven环境变量配置
    PowerDesigner逆向导入MYSQL数据库并显示中文注释(转载)
    web_custom_request函数详解(转载)
  • 原文地址:https://www.cnblogs.com/ke-T3022/p/8385455.html
Copyright © 2011-2022 走看看