zoukankan      html  css  js  c++  java
  • POJ2586 Y2K Accounting Bug 解题报告

    Description

    Accounting for Computer Machinists (ACM) has sufferred from the Y2K bug and lost some vital data for preparing annual report for MS Inc.
    All what they remember is that MS Inc. posted a surplus or a deficit each month of 1999 and each month when MS Inc. posted surplus, the amount of surplus was s and each month when MS Inc. posted deficit, the deficit was d. They do not remember which or how many months posted surplus or deficit. MS Inc., unlike other companies, posts their earnings for each consecutive 5 months during a year. ACM knows that each of these 8 postings reported a deficit but they do not know how much. The chief accountant is almost sure that MS Inc. was about to post surplus for the entire year of 1999. Almost but not quite.
    Write a program, which decides whether MS Inc. suffered a deficit during 1999, or if a surplus for 1999 was possible, what is the maximum amount of surplus that they can post.

    Input

    Input is a sequence of lines, each containing two positive integers s and d.

    Output

    For each line of input, output one line containing either a single integer giving the amount of surplus for the entire year, or output Deficit if it is impossible.

    Sample Input

    59 237 375 743 200000 849694 2500000 8000000

    Sample Output

    116 28 300612 Deficit
    
    

    分析:

        已知一年中,所有的连续的5个月是亏损的(如1-5月,2-6月。。。8-12月共8个),每个月要么收益s,要么亏损d,
    求一年中最大收益。这数据量什么都不想了直接暴力搜索加个树状数组优化下算是用了点心了
    #include <iostream>
    #include <cstring>
    using namespace std;
    int f[13],ans,s,d;
    void update(int x,int k){
          for(;x<=12;x+=(-x)&x) f[x]+=k;
    }
    int sum(int x){
          int s=0;
          for(;x>0;x-=(-x)&x) s+=f[x];
          return s;
    }
    void make(int k){
          if(k==13) {
                ans=max(sum(12),ans);
                return;
          }
          update(k,s+d);
          int i;
          for(i=5;i<=12;i++){
                if(sum(i)-sum(i-5)>0) break;
          }
          if(i<13) {
                      update(k,-s-d);
                      make(k+1);
          }
          else{
                      make(k+1);
                      update(k,-s-d);
                      make(k+1);
          }
    }
    int main(){
          while(cin>>s>>d) {
                ans=-1e8;
                memset(f,0,sizeof f);
                for(int i=1;i<=12;i++) update(i,-d);
                make(1);
                if(ans<0) cout<<"Deficit"<<endl;
                else
                      cout<<ans<<endl;
         }
         return 0;
    }
    
    http://www.cnblogs.com/keam37/ keam所有 转载请注明出处
  • 相关阅读:
    在centOS上安装oracle出现java.lang.NoClassDefFoundError问题及解决方法
    centos6.5下安装oracle11g
    配置单点登录
    CentOS 环境变量编辑、保存、立即生效的方法
    python如何调用C语言程序
    python生成exe可执行程序
    python的encode()和decode()函数
    python 获取时间
    python修改字符串的值
    python enumerate()函数
  • 原文地址:https://www.cnblogs.com/keam37/p/3749129.html
Copyright © 2011-2022 走看看