zoukankan      html  css  js  c++  java
  • hdu-Coins

    http://acm.hdu.edu.cn/showproblem.php?pid=2844


    Problem Description
    Whuacmers use coins.They have coins of value A1,A2,A3...An Silverland dollar. One day Hibix opened purse and found there were some coins. He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn't know the exact price of the watch.

    You are to write a program which reads n,m,A1,A2,A3...An and C1,C2,C3...Cn corresponding to the number of Tony's coins of value A1,A2,A3...An then calculate how many prices(form 1 to m) Tony can pay use these coins.
     
    Input
    The input contains several test cases. The first line of each test case contains two integers n(1 ≤ n ≤ 100),m(m ≤ 100000).The second line contains 2n integers, denoting A1,A2,A3...An,C1,C2,C3...Cn (1 ≤ Ai ≤ 100000,1 ≤ Ci ≤ 1000). The last test case is followed by two zeros.
     
    Output
    For each test case output the answer on a single line.
     
    Sample Input
    3 10 1 2 4 2 1 1 2 5 1 4 2 1 0 0
     
    Sample Output
    8 4
     


    此题是多重背包的问题,比较麻烦,看了别人的代码,用到了转换成二进制的思想。

    分析:

    #include<iostream>
    using namespace std;
    int main()
    {
        int i,j,k;
        int n,m;
        int dp[100044];
        int val[100004];
        int num[100004];
        while(cin>>n>>m)
        {
              if((n==0)&&(m==0))
              break;
              for(i=0;i<n;i++)
              cin>>val[i];
              for(i=0;i<n;i++)
              cin>>num[i];
              for(i=0;i<100000;i++)
              dp[i]=-9999999;
              dp[0]=1;
              for(i=0;i<n;i++)
              {
                  if(val[i]*num[i]>=m)
                  {
                      for(j=val[i];j<m;j++)
                      dp[j]=max(dp[j],dp[j-val[i]]+val[i]);
                  }
                  else
                  {
                      for(k=1;k<=num[i];k=k*2)
                      {
                          for(j=m;j>=val[i]*k;j--)
                          {
                              dp[j]=max(dp[j],dp[j-val[i]*k]+val[i]*k);
                          }
                          num[i]=num[i]-k;
                      }
                      if(val[i]>0)
                      {
                         for(j=m;j>=val[i]*num[i];j--)
                         dp[j]=max(dp[j],dp[j-val[i]*num[i]]+val[i]*num[i]);
                      }
                  }
    
              }
              int count=0;
              for(j=1;j<=m;j++)
              {
                  if(dp[j]>=0)
                  count++;
              }
             cout<<count<<endl;
        }
        return 0;
    }
    


  • 相关阅读:
    c++中的extern
    DOS性能监视器
    谈谈.NET中的内存管理(转帖)
    static_cast和dynamic_cast
    关于对EventHandler 和e的理解(转帖)
    使用Windows Mobile 6模拟器上网的步骤(转帖)
    接口抽象类类
    当前不会命中断点 尚未加载指定的模块 windows mobile
    C# 编码的双重检验锁定
    Loadrunner 监控Unix系统性能指标的解释
  • 原文地址:https://www.cnblogs.com/keanuyaoo/p/3260414.html
Copyright © 2011-2022 走看看