zoukankan      html  css  js  c++  java
  • HDU 1241 Oil Deposits DFS(深度优先搜索) 和 BFS(广度优先搜索)

    Oil Deposits

    Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 8274 Accepted Submission(s): 4860

    Problem Description
    The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.
     
    Input
    The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.
     
    Output
    For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.
     
    Sample Input
    1 1 * 3 5 *@*@* **@** *@*@* 1 8 @@****@* 5 5 ****@ *@@*@ *@**@ @@@*@ @@**@ 0 0
     
    Sample Output
    0 1 2 2
     


    方法一:DFS(深度优先搜索)

    import java.io.*;
    import java.util.*;
    public class Main {
    	public  char ch[][];
    	public int fx[]={1,1,1,-1,-1,-1,0,0};
    	public int fy[]={0,1,-1,0,1,-1,1,-1};
    	public int m,n;
    	public static void main(String[] args) {
    		new Main().work();
    	}
    	public void work(){
    		Scanner sc=new Scanner(new BufferedInputStream(System.in));
    		while(sc.hasNext()){
    			m=sc.nextInt();
    			n=sc.nextInt();
    			ch=new char[m][n];
    			if(m==0)
    				System.exit(0);
    			for(int i=0;i<m;i++){
    				String s=sc.next();
    				ch[i]=s.toCharArray();
    			}
    			int toal=0;
    			for(int i=0;i<m;i++){
    				for(int j=0;j<n;j++){
    					if(ch[i][j]=='@'){
    						toal++;
    						dfs(i,j);
    					}
    				}
    			}
    			System.out.println(toal);
    		}
    	}
    	public void dfs(int x,int y){
    		for(int i=0;i<8;i++){
    			int px=x+fx[i];
    			int py=y+fy[i];
    			if(check(px,py)){
    				ch[px][py]='*';
    				dfs(px,py);
    			}
    		}
    	}
    	public boolean check(int px,int py){
    		if(px<0||px>m-1||py<0||py>n-1||ch[px][py]!='@')
    			return false;
    		return true;
    	}
    }
    



    方法二BFS(广度优先搜索)

    import java.io.*;
    import java.util.*;
    public class Main {
    	public int m,n;
    	public char ch[][];
    	public Queue<Bnode> list=new LinkedList<Bnode>();
    	public int fx[]={1,1,1,-1,-1,-1,0,0};
    	public int fy[]={0,1,-1,0,1,-1,1,-1};
    	public static void main(String[] args) {
    		new Main().work();
    	}
    	public void work(){
    		Scanner sc=new Scanner(new BufferedInputStream(System.in));
    		while(sc.hasNext()){
    			list.clear();
    			m=sc.nextInt();
    			n=sc.nextInt();
    			if(m==0)
    				System.exit(0);
    			ch=new char[m][n];
    			for(int i=0;i<m;i++){
    				String s=sc.next();
    				ch[i]=s.toCharArray();
    			}
    			int total=0;
    			for(int i=0;i<m;i++){
    				for(int j=0;j<n;j++){
    					if(ch[i][j]=='@'){
    						total++;
    						Bnode bnode=new Bnode();
    						bnode.x=i;
    						bnode.y=j;
    						list.add(bnode);
    						
    						BFS();
    					}
    				}
    			}
    			System.out.println(total);
    		}
    	}
    	public void BFS(){
    		while(!list.isEmpty()){
    			Bnode bnode=list.poll();
    			for(int i=0;i<8;i++){
    				int px=bnode.x+fx[i];
    				int py=bnode.y+fy[i];
    				if(check(px,py)){
    					ch[px][py]='*';
    					Bnode t=new Bnode();
    					t.x=px;
    					t.y=py;
    					list.add(t);
    				}
    			}
    		}
    	}
    	public boolean check(int px,int py){
    		if(px<0||px>m-1||py<0||py>n-1||ch[px][py]!='@')
    			return false;
    		return true;
    	}
    }
    class Bnode {
    	int x;
    	int y;
    }


  • 相关阅读:
    U盘修复
    在tomcat中配置jdk的不同版本
    集​群​t​o​m​c​a​t​+​a​p​a​c​h​e​配​置​文​档
    如何挂自己的web项目(免费拥有自己的网站及域名)
    JQuery对表格进行排序
    JQuery中对各种域进行隐藏和显示操作
    大文件批量上传断点续传文件秒传
    web 开发常用字符串表达式匹配
    spring 工具类大集合
    spring 是如何注入对象的和bean 创建过程分析
  • 原文地址:https://www.cnblogs.com/keanuyaoo/p/3262946.html
Copyright © 2011-2022 走看看