zoukankan      html  css  js  c++  java
  • HDU 1241 Oil Deposits DFS(深度优先搜索) 和 BFS(广度优先搜索)

    Oil Deposits

    Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 8274 Accepted Submission(s): 4860

    Problem Description
    The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.
     
    Input
    The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.
     
    Output
    For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.
     
    Sample Input
    1 1 * 3 5 *@*@* **@** *@*@* 1 8 @@****@* 5 5 ****@ *@@*@ *@**@ @@@*@ @@**@ 0 0
     
    Sample Output
    0 1 2 2
     


    方法一:DFS(深度优先搜索)

    import java.io.*;
    import java.util.*;
    public class Main {
    	public  char ch[][];
    	public int fx[]={1,1,1,-1,-1,-1,0,0};
    	public int fy[]={0,1,-1,0,1,-1,1,-1};
    	public int m,n;
    	public static void main(String[] args) {
    		new Main().work();
    	}
    	public void work(){
    		Scanner sc=new Scanner(new BufferedInputStream(System.in));
    		while(sc.hasNext()){
    			m=sc.nextInt();
    			n=sc.nextInt();
    			ch=new char[m][n];
    			if(m==0)
    				System.exit(0);
    			for(int i=0;i<m;i++){
    				String s=sc.next();
    				ch[i]=s.toCharArray();
    			}
    			int toal=0;
    			for(int i=0;i<m;i++){
    				for(int j=0;j<n;j++){
    					if(ch[i][j]=='@'){
    						toal++;
    						dfs(i,j);
    					}
    				}
    			}
    			System.out.println(toal);
    		}
    	}
    	public void dfs(int x,int y){
    		for(int i=0;i<8;i++){
    			int px=x+fx[i];
    			int py=y+fy[i];
    			if(check(px,py)){
    				ch[px][py]='*';
    				dfs(px,py);
    			}
    		}
    	}
    	public boolean check(int px,int py){
    		if(px<0||px>m-1||py<0||py>n-1||ch[px][py]!='@')
    			return false;
    		return true;
    	}
    }
    



    方法二BFS(广度优先搜索)

    import java.io.*;
    import java.util.*;
    public class Main {
    	public int m,n;
    	public char ch[][];
    	public Queue<Bnode> list=new LinkedList<Bnode>();
    	public int fx[]={1,1,1,-1,-1,-1,0,0};
    	public int fy[]={0,1,-1,0,1,-1,1,-1};
    	public static void main(String[] args) {
    		new Main().work();
    	}
    	public void work(){
    		Scanner sc=new Scanner(new BufferedInputStream(System.in));
    		while(sc.hasNext()){
    			list.clear();
    			m=sc.nextInt();
    			n=sc.nextInt();
    			if(m==0)
    				System.exit(0);
    			ch=new char[m][n];
    			for(int i=0;i<m;i++){
    				String s=sc.next();
    				ch[i]=s.toCharArray();
    			}
    			int total=0;
    			for(int i=0;i<m;i++){
    				for(int j=0;j<n;j++){
    					if(ch[i][j]=='@'){
    						total++;
    						Bnode bnode=new Bnode();
    						bnode.x=i;
    						bnode.y=j;
    						list.add(bnode);
    						
    						BFS();
    					}
    				}
    			}
    			System.out.println(total);
    		}
    	}
    	public void BFS(){
    		while(!list.isEmpty()){
    			Bnode bnode=list.poll();
    			for(int i=0;i<8;i++){
    				int px=bnode.x+fx[i];
    				int py=bnode.y+fy[i];
    				if(check(px,py)){
    					ch[px][py]='*';
    					Bnode t=new Bnode();
    					t.x=px;
    					t.y=py;
    					list.add(t);
    				}
    			}
    		}
    	}
    	public boolean check(int px,int py){
    		if(px<0||px>m-1||py<0||py>n-1||ch[px][py]!='@')
    			return false;
    		return true;
    	}
    }
    class Bnode {
    	int x;
    	int y;
    }


  • 相关阅读:
    跨平台技术
    Unity和虚幻的比较
    商业模式(四):群硕软件,欧美客户为主的软件外包
    商业模式(四):群硕软件,欧美客户为主的软件外包
    Volley完全解析
    双十一京东图书购物清单,动动脑子节省300元
    双十一京东图书购物清单,动动脑子节省300元
    ListView异步加载图片,完美实现图文混排
    使用DrawerLayout实现QQ5.0侧拉菜单效果
    商业模式(三):P2P网贷平台,毛利润测算
  • 原文地址:https://www.cnblogs.com/keanuyaoo/p/3262946.html
Copyright © 2011-2022 走看看