zoukankan      html  css  js  c++  java
  • POJ 1472 Coins (多重背包+滚动数组)

    Coins

    Time Limit: 3000MS

     

    Memory Limit: 30000K

    Total Submissions: 25827

     

    Accepted: 8741

    Description

    People in Silverland use coins.They have coins of value A1,A2,A3...An Silverland dollar.One day Tony opened his money-box and found there were some coins.He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn't know the exact price of the watch.
    You are to write a program which reads n,m,A1,A2,A3...An and C1,C2,C3...Cn corresponding to the number of Tony's coins of value A1,A2,A3...An then calculate how many prices(form 1 to m) Tony can pay use these coins.

    Input

    The input contains several test cases. The first line of each test case contains two integers n(1<=n<=100),m(m<=100000).The second line contains 2n integers, denoting A1,A2,A3...An,C1,C2,C3...Cn (1<=Ai<=100000,1<=Ci<=1000). The last test case is followed by two zeros.

    Output

    For each test case output the answer on a single line.

    Sample Input

    3 10
    1 2 4 2 1 1
    2 5
    1 4 2 1
    0 0
    

    Sample Output

    8
    4
    
     
    题意:给出几种面值的钱币和对应的个数,看能否凑出1-m中的各个面值。
     
    方法一:多重背包

    import java.io.*;
    import java.util.*;
    /*
     *
     * author : deng_hui_long 
     * Date   : 2013-8-31
     *
    */
    public class Main {
    	int n,m;
    	int dp[]=new int[1000001];
    	public static void main(String[] args) {
    		new Main().work();
    	}
    	void work(){
    		Scanner sc=new Scanner(new BufferedInputStream(System.in));
    		while(sc.hasNext()){
    			n=sc.nextInt();
    			m=sc.nextInt();
    			if(n==0&&m==0)
    				break;
    			Node node=new Node();
    			Arrays.fill(dp, 0);
    			
    			for(int i=0;i<n;i++){
    				node.a[i]=sc.nextInt();
    			}
    			
    			for(int i=0;i<n;i++){
    				node.c[i]=sc.nextInt();
    			}
    			
    			for(int i=0;i<n;i++){
    				multiplePack(node.a[i],node.a[i],node.c[i]);
    			}
    			int ans=0;
    			for(int i=1;i<=m;i++){
    				if(dp[i]==i)
    					ans++;
    			}
    			System.out.println(ans);
    		}
    	}
    	//多重背包
    	void multiplePack(int cost,int weight,int amount){
    		if(cost*amount>=m)//大于最大价值,按完全背包处理
    			completePack(cost,weight);
    		else{//小于最大价值,按01背包处理
    			int k=1;
    			while(k<amount){
    				zeroOnePack(k*cost,k*weight);
    				amount-=k;
    				k<<=1;//右一位,表示乘以2
    			}
    			zeroOnePack(amount*cost,amount*weight);
    		}
    	}
    	//完全背包
    	void completePack(int cost,int weight){
    		for(int i=cost;i<=m;i++){
    			dp[i]=Math.max(dp[i],dp[i-cost]+weight);
    		}
    	}
    	//01背包
    	void zeroOnePack(int cost,int weight){
    		for(int i=m;i>=cost;i--){
    			dp[i]=Math.max(dp[i],dp[i-cost]+weight);
    		}
    	}
    	class Node{
    		int a[]=new int[n];
    		int c[]=new int[n];
    	}
    }
    

    方法二:滚动数组

    import java.io.*;
    import java.util.*;
    /*
     *
     * author : deng_hui_long 
     * Date   : 2013-8-31
     *
    */
    public class Main {
    	int n,m,MAX=100001;
    	boolean dp[]=new boolean[MAX];
    	public static void main(String[] args) {
    		new Main().work();
    	}
    	void work(){
    		Scanner sc=new Scanner(new BufferedInputStream(System.in));
    		while(sc.hasNext()){
    			n=sc.nextInt();
    			m=sc.nextInt();
    			if(n==0&&m==0)
    				break;
    			Node node=new Node();
    			for(int i=0;i<n;i++){
    				node.a[i]=sc.nextInt();
    			}
    			for(int i=0;i<n;i++){
    				node.c[i]=sc.nextInt();
    			}
    			Arrays.fill(dp,false);
    			dp[0]=true;
    			int ans=0;
    			//滚动数组
    			for(int i=0;i<n;i++){
    				int u[]=new int[MAX];
    				for(int j=node.a[i];j<=m;j++){
    					if(!dp[j]&&dp[j-node.a[i]]&&node.c[i]>u[j-node.a[i]]){
    						dp[j]=true;
    						u[j]=u[j-node.a[i]]+1;
    						ans++;
    					}
    				}
    			}
    			System.out.println(ans);
    		}
    	}
    	class Node{
    		int a[]=new int[n];
    		int c[]=new int[n];
    	}
    }
    


     

    
    
  • 相关阅读:
    Cannot set property 'branchdata' of undefined
    关闭Vue Eslint语法检查
    Webpack前世今生
    SpringCloud 之 Netflix Hystrix 服务监控
    Spring Cloud 之 Netflix Hystrix 服务容错
    Java设计模式之建造者模式(Builder Pattern)
    Java设计模式之工厂模式(Factory Pattern)
    数据库表的字段有默认值,如何修改或者去掉这个默认值
    前端基础进阶(十五):详解 ES6 Modules
    JS基础知识题(中)作用域、闭包
  • 原文地址:https://www.cnblogs.com/keanuyaoo/p/3294005.html
Copyright © 2011-2022 走看看