zoukankan      html  css  js  c++  java
  • HDU 472 Hamming Distance (随机数)

    Hamming Distance

    Time Limit: 6000/3000 MS (Java/Others) Memory Limit: 65535/65535 K (Java/Others)
    Total Submission(s): 1127 Accepted Submission(s): 425


    Problem Description
    (From wikipedia) For binary strings a and b the Hamming distance is equal to the number of ones in a XOR b. For calculating Hamming distance between two strings a and b, they must have equal length.
    Now given N different binary strings, please calculate the minimum Hamming distance between every pair of strings.
     
    Input
    The first line of the input is an integer T, the number of test cases.(0<T<=20) Then T test case followed. The first line of each test case is an integer N (2<=N<=100000), the number of different binary strings. Then N lines followed, each of the next N line is a string consist of five characters. Each character is '0'-'9' or 'A'-'F', it represents the hexadecimal code of the binary string. For example, the hexadecimal code "12345" represents binary string "00010010001101000101".
     
    Output
    For each test case, output the minimum Hamming distance between every pair of strings.
     
    Sample Input
    2 2 12345 54321 4 12345 6789A BCDEF 0137F
     
    Sample Output
    6 7
     

    题意:就是任意两个16进制字符串XOR,在 所有结果中,求结果以二进制表示时,含1个数最少是多少。

    import java.io.*;
    import java.util.*;
    public class Main {
    	BufferedReader bu;
    	PrintWriter pw;
    	int t,n,min;
    	public static void main(String[] args) throws IOException{
    		new Main().work();
    	}
    	void work() throws IOException{
    		bu=new BufferedReader(new InputStreamReader(System.in));
    		pw=new PrintWriter(new OutputStreamWriter(System.out),true);
    		t=Integer.parseInt(bu.readLine());
    		while(t--!=0){
    			n=Integer.parseInt(bu.readLine());
    			String str[]=new String[n];
    			for(int i=0;i<n;i++){
    				str[i]=bu.readLine();
    			}
    			min=0xfffffff;
    			Random da=new Random(1);
    			for(int i=1;i<1000000;i++){
    				int x=da.nextInt()%n;
    				int y=da.nextInt()%n;
    				
    				if(x!=y&&x>=0&&y>=0){
    					int num1=Integer.parseInt(str[x],16);
    					int num2=Integer.parseInt(str[y],16);
    					int num=num1^num2;
    					getCount(num);
    				}
    			}
    			pw.println(min);
    		}
    	}
    	void getCount(int num){
    		int len=0;
    		int count=0;
    		while((num>=(1<<len))){
    			if((num&(1<<len))!=0){
    				count++;
    			}
    			len++;
    		}
    		min=Math.min(min,count);
    		
    	}
    }
    


     

  • 相关阅读:
    Effective C++ 笔记 —— Item 6: Explicitly disallow the use of compiler-generated functions you do not want.
    Oracle DataBase 用户管理与权限管理
    企业邮箱配置SSL发送邮件
    如何知道安装程序在进行安装时对你的电脑到底做了什么?
    架构师笔记:康威定律
    conda 源配置
    myBatis的批量提交方式
    转载:request_time和upstream_response_time详解
    [PowerShell]比较运算符
    [PowerShell]字符串
  • 原文地址:https://www.cnblogs.com/keanuyaoo/p/3318004.html
Copyright © 2011-2022 走看看