zoukankan      html  css  js  c++  java
  • poj_1163

    题目:

    Description
    
    7
    3   8
    8   1   0
    2   7   4   4
    4   5   2   6   5
    
    (Figure 1)
    Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right. 
    Input
    
    Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.
    Output
    
    Your program is to write to standard output. The highest sum is written as an integer.
    Sample Input
    
    5
    7
    3 8
    8 1 0 
    2 7 4 4
    4 5 2 6 5
    Sample Output
    
    30

    分析:一个dp问题,首先写出状态定义,这里可以用d(x,y)表示二维数组中row = x, col = y 的结点的到最底层(row最大)时的和的最大值,那么问题就可以转化为求d(1,1)(我是把数据从1开始放置的);可以写出状态转移方程:d(x, y) = v(x, y) + max(d(x+1, y), d(x+1, y+1));

    代码如下:

    #include<stdio.h>
    
    int v[60][60];
    int d[60][60];
    int main() {
        int n, i, j, max;
        scanf("%d", &n);
        for(i = 1; i <= n; ++i) {
            for(j = 1; j <= i; ++j) {
                scanf("%d", &v[i][j]);
            }
        }
    
        for(i = n; i >= 1; --i){
            for(j = 1; j <= i; ++j) {
                if(i == n) {
                    d[i][j] = v[i][j]; 
                } else {
                    max = (d[i+1][j] > d[i+1][j+1] ? d[i+1][j] : d[i+1][j+1]);
                    d[i][j] = max + v[i][j];
                }
            }
        }
        printf("%d", d[1][1]);
    }
  • 相关阅读:
    LeetCode——面试题57
    翻译——5_Summary, Conclusion and Discussion
    LeetCode——114. 二叉树展开为链表
    LeetCode——1103. 分糖果 II
    LeetCode——337. 打家劫舍 III
    LeetCode——994. 腐烂的橘子
    Python——潜在会员用户预测
    Vue中div高度自适应
    webpack中使用vue-resource
    Mint UI组件库 和 Mui
  • 原文地址:https://www.cnblogs.com/kinthon/p/4489565.html
Copyright © 2011-2022 走看看