zoukankan      html  css  js  c++  java
  • Stockbroker Grapevine

    Stockbroker Grapevine
    Time Limit: 1000MS   Memory Limit: 10000K
    Total Submissions: 18719   Accepted: 10114

    Description

    Stockbrokers are known to overreact to rumours. You have been contracted to develop a method of spreading disinformation amongst the stockbrokers to give your employer the tactical edge in the stock market. For maximum effect, you have to spread the rumours in the fastest possible way. 

    Unfortunately for you, stockbrokers only trust information coming from their "Trusted sources" This means you have to take into account the structure of their contacts when starting a rumour. It takes a certain amount of time for a specific stockbroker to pass the rumour on to each of his colleagues. Your task will be to write a program that tells you which stockbroker to choose as your starting point for the rumour, as well as the time it will take for the rumour to spread throughout the stockbroker community. This duration is measured as the time needed for the last person to receive the information.

    Input

    Your program will input data for different sets of stockbrokers. Each set starts with a line with the number of stockbrokers. Following this is a line for each stockbroker which contains the number of people who they have contact with, who these people are, and the time taken for them to pass the message to each person. The format of each stockbroker line is as follows: The line starts with the number of contacts (n), followed by n pairs of integers, one pair for each contact. Each pair lists first a number referring to the contact (e.g. a '1' means person number one in the set), followed by the time in minutes taken to pass a message to that person. There are no special punctuation symbols or spacing rules. 

    Each person is numbered 1 through to the number of stockbrokers. The time taken to pass the message on will be between 1 and 10 minutes (inclusive), and the number of contacts will range between 0 and one less than the number of stockbrokers. The number of stockbrokers will range from 1 to 100. The input is terminated by a set of stockbrokers containing 0 (zero) people. 

    Output

    For each set of data, your program must output a single line containing the person who results in the fastest message transmission, and how long before the last person will receive any given message after you give it to this person, measured in integer minutes. 
    It is possible that your program will receive a network of connections that excludes some persons, i.e. some people may be unreachable. If your program detects such a broken network, simply output the message "disjoint". Note that the time taken to pass the message from person A to person B is not necessarily the same as the time taken to pass it from B to A, if such transmission is possible at all.

    Sample Input

    3
    2 2 4 3 5
    2 1 2 3 6
    2 1 2 2 2
    5
    3 4 4 2 8 5 3
    1 5 8
    4 1 6 4 10 2 7 5 2
    0
    2 2 5 1 5
    0

    Sample Output

    3 2
    3 10

    Source

    #include<iostream>
    #define INFINITE (0x0FFFFFFF)
    #define NOT_EXIST (0x80000001)

    using namespace std;




    int Dist[200][200];



    int main()
    {


    int N;

    while( cin >> N )
    {
    if( N == 0 )
    {
    break;
    }

    //clear
    for( int i = 1 ; i <= N ; ++i )
    {
    for( int j = 1 ; j <= N ; ++j )
    {
    if( i == j )
    {
    Dist[i][j] = 0;
    }
    else
    {
    Dist[i][j] = INFINITE;
    }
    }
    }

    //get the matrix
    for( int i = 1 ; i <= N ; ++i )
    {
    int n_c;
    cin >> n_c;
    while( n_c-- )
    {
    int c;
    int t;
    cin >> c >> t;

    Dist[i][c] = t;
    }
    }

    //Floyd
    for( int inter = 1 ; inter <= N ; ++ inter )
    {
    for( int start = 1 ; start <= N ; ++ start )
    {
    for( int end = 1 ; end <= N ; ++end )
    {
    if( start != end )
    {
    if( Dist[start][inter] + Dist[inter][end] < Dist[start][end] )
    {
    Dist[start][end] = Dist[start][inter] + Dist[inter][end];
    }
    }

    }

    }
    }

    //output
    int min = INFINITE;
    int max = 0;
    int index = -1;

    for( int i = 1 ; i <= N ; ++i )
    {
    max = 0;
    for( int j = 1 ; j <= N ; ++j )
    {
    if( Dist[i][j] > max )
    {
    max = Dist[i][j];
    }
    }

    if( max < min )
    {
    min = max;
    index = i;
    }

    }

    if( min == INFINITE )
    {
    cout << "disjoint" << endl;
    }
    else
    {
    cout << index << " " << min << endl;
    }


    }



    return 0;
    }
  • 相关阅读:
    误操作 rpm -e --nodeps zlib
    Raid阵列之简单介绍
    GpG使用指南
    hadoop系统的端口
    网站日志流量复杂分析
    Flume在企业大数据仓库架构中位置及功能
    Hue的安装与部署
    Hive中的数据倾斜
    Hive的三种Join方式
    如何每日增量加载数据到Hive分区表
  • 原文地址:https://www.cnblogs.com/kking/p/2333757.html
Copyright © 2011-2022 走看看