zoukankan      html  css  js  c++  java
  • Ubiquitous Religions

    Ubiquitous Religions
    Time Limit: 5000MS   Memory Limit: 65536K
    Total Submissions: 15947   Accepted: 7682

    Description

    There are so many different religions in the world today that it is difficult to keep track of them all. You are interested in finding out how many different religions students in your university believe in. 

    You know that there are n students in your university (0 < n <= 50000). It is infeasible for you to ask every student their religious beliefs. Furthermore, many students are not comfortable expressing their beliefs. One way to avoid these problems is to ask m (0 <= m <= n(n-1)/2) pairs of students and ask them whether they believe in the same religion (e.g. they may know if they both attend the same church). From this data, you may not know what each person believes in, but you can get an idea of the upper bound of how many different religions can be possibly represented on campus. You may assume that each student subscribes to at most one religion.

    Input

    The input consists of a number of cases. Each case starts with a line specifying the integers n and m. The next m lines each consists of two integers i and j, specifying that students i and j believe in the same religion. The students are numbered 1 to n. The end of input is specified by a line in which n = m = 0.

    Output

    For each test case, print on a single line the case number (starting with 1) followed by the maximum number of different religions that the students in the university believe in.

    Sample Input

    10 9
    1 2
    1 3
    1 4
    1 5
    1 6
    1 7
    1 8
    1 9
    1 10
    10 4
    2 3
    4 5
    4 8
    5 8
    0 0
    

    Sample Output

    Case 1: 1
    Case 2: 7
    

    Hint

    Huge input, scanf is recommended.

    Source

    #include <iostream>
    #include <fstream>
    #include <vector>
    #include <string>
    #include <algorithm>
    #include <map>
    #include <stack>
    #include <cmath>
    #include <queue>
    #include <set>
    #include <list>
    #define REP(i,j,k) for( int i = j ; i < k ; ++i)


    using namespace std;



    int Set[50001];



    int Find( int t )
    {
    int n = t;
    while( Set[n] != 0 )
    {
    n = Set[n];
    }

    if( Set[t] != 0 )
    {
    Set[t] = n;
    }


    return n;
    }

    void Union( int a , int b )
    {
    int m = Find(a);
    int n = Find(b);
    if( m != n )
    {
    Set[m] = n;
    }
    }



    int main()
    {

    int N,M;

    int num_case = 1;

    while( cin >> N >> M )
    {
    if( N == 0 && M == 0 )
    {
    break;
    }
    else
    {
    int max = 0;
    REP(i,1,N + 1)
    {
    Set[i] = 0;
    }

    REP(i,0,M)
    {
    int a,b;
    scanf("%d %d\n" , &a ,&b);

    Union(a , b);
    }

    REP(i,1,N+1)
    {
    if( Set[i] == 0 )
    {
    ++max;
    }
    }

    printf( "Case %d: %d\n" , num_case ++ , max );
    }

    }


    return 0;

    }
  • 相关阅读:
    更新处理函数在对话框的菜单中不能工作
    msn登录时80048820错误
    C#编程指南:使用属性
    sqlserver中''与null的区别
    IP地址与主机名识别问题
    给EXCEL表格奇偶行设置不同的背景颜色
    sqlserver2000发布订阅
    Excel数据导入到Sqlserver2000
    SQLSERVER 获取时间 Convert函数的应用
    对路径“C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322\Temporary ASP.NET Files\aa\……”的访问被拒绝
  • 原文地址:https://www.cnblogs.com/kking/p/2335182.html
Copyright © 2011-2022 走看看