zoukankan      html  css  js  c++  java
  • 1013. Battle Over Cities

    1013. Battle Over Cities (25)

    时间限制
    400 ms
    内存限制
    32000 kB
    代码长度限制
    16000 B
    判题程序
    Standard
    作者
    CHEN, Yue

    It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.

    For example, if we have 3 cities and 2 highways connecting city1-city2 and city1-city3. Then if city1 is occupied by the enemy, we must have 1 highway repaired, that is the highway city2-city3.

    Input

    Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.

    Output

    For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.

    Sample Input
    3 2 3
    1 2
    1 3
    1 2 3
    
    Sample Output
    1
    0
    0
    
    #include <iostream>
    #include <fstream>
    #include <vector>
    #include <string>
    #include <algorithm>
    #include <map>
    #include <stack>
    #include <cmath>
    #include <queue>
    #include <set>
    #define REP(i,j,k) for( int i = j ; i < k ; ++i)


    using namespace std;


    struct Highway
    {
    int from;
    int to;
    };


    int Find( int *S , int target )
    {
    while( S[target] != 0 )
    {
    target = S[target];
    }

    return target;

    }



    void Union( int* S , int s1 , int s2 )
    {
    S[Find(S,s2)] = Find( S,s1);
    }




    int main()
    {



    int N, M, K;

    vector<Highway> highways;
    highways.clear();

    cin >> N >> M >> K;

    REP(i,0,M)
    {
    Highway hw1;
    cin >> hw1.from >> hw1.to;
    Highway hw2;
    hw2.from = hw1.to;
    hw2.to = hw1.from;

    highways.push_back(hw1);
    highways.push_back(hw2);
    }


    int set[1001];
    REP(i,0,K)
    {
    int city;
    cin >> city;

    REP(j,1,N+1)
    {
    set[j] = 0;
    }

    REP(j,0,highways.size())
    {
    if( highways[j].from != city && highways[j].to!= city )
    {
    if( Find(set, highways[j].from ) != Find(set, highways[j].to ) )
    {
    Union( set , highways[j].from , highways[j].to );
    }

    }
    }

    int n = 0;

    REP(j,1,N+1)
    {
    if( set[j] == 0 && j != city )
    {
    ++n;
    }
    }

    cout << n - 1 << endl;


    }

    return 0;

    }


  • 相关阅读:
    三角形的最大周长
    Java 虚拟机运行时数据区详解
    四数相加 II
    Java 注解详解
    四因数
    【论文笔记+复现踩坑】End-to-end Recovery of Human Shape and Pose(CVPR 2018)
    假如 Web 当初不支持动态化
    保姆级干货分享
    C# ±180的值转成0-360
    C# 校验算法小结
  • 原文地址:https://www.cnblogs.com/kking/p/2336137.html
Copyright © 2011-2022 走看看