zoukankan      html  css  js  c++  java
  • poj 1543 Perfect Cubes (暴搜)

    Perfect Cubes
    Time Limit: 1000MS   Memory Limit: 10000K
    Total Submissions: 15302   Accepted: 7936

    Description

    For hundreds of years Fermat's Last Theorem, which stated simply that for n > 2 there exist no integers a, b, c > 1 such that a^n = b^n + c^n, has remained elusively unproven. (A recent proof is believed to be correct, though it is still undergoing scrutiny.) It is possible, however, to find integers greater than 1 that satisfy the "perfect cube" equation a^3 = b^3 + c^3 + d^3 (e.g. a quick calculation will show that the equation 12^3 = 6^3 + 8^3 + 10^3 is indeed true). This problem requires that you write a program to find all sets of numbers {a,b,c,d} which satisfy this equation for a <= N.

    Input

    One integer N (N <= 100).

    Output

    The output should be listed as shown below, one perfect cube per line, in non-decreasing order of a (i.e. the lines should be sorted by their a values). The values of b, c, and d should also be listed in non-decreasing order on the line itself. There do exist several values of a which can be produced from multiple distinct sets of b, c, and d triples. In these cases, the triples with the smaller b values should be listed first.

    Sample Input

    24

    Sample Output

    Cube = 6, Triple = (3,4,5)
    Cube = 12, Triple = (6,8,10)
    Cube = 18, Triple = (2,12,16)
    Cube = 18, Triple = (9,12,15)
    Cube = 19, Triple = (3,10,18)
    Cube = 20, Triple = (7,14,17)
    Cube = 24, Triple = (12,16,20)

    Java AC 代码

    import java.util.Scanner;
    
    public class Main {
        
        public static void main(String[] args) {
            Scanner sc = new Scanner(System.in);
            int n = sc.nextInt();
            for(int i = 2; i <= n; i++)
                for(int a = 2; a < i; a++) 
                    for(int b = a; b < i; b++) 
                        for(int c = b; c < i; c++) {
                            if(i*i*i == a*a*a + b*b*b + c*c*c) {
                                System.out.println("Cube = " + i +", Triple = (" + a + "," + b + "," + c +")");
                            }
                        }
        }
    }
  • 相关阅读:
    第八讲、原型模式
    第七讲、建造者模式
    第六讲、抽象工厂模式
    第五讲、工厂方法模式
    第四讲、简单工厂模式
    第三讲、策略模式
    第二讲、备忘录模式
    第一讲、单例模式
    二、中国黑客
    java 17
  • 原文地址:https://www.cnblogs.com/kkkkkk/p/5539138.html
Copyright © 2011-2022 走看看