zoukankan      html  css  js  c++  java
  • Fibonacci Again

    Fibonacci Again

    Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
    Total Submission(s) : 13   Accepted Submission(s) : 5
    Problem Description
    There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).
     
    Input
    Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).
     
    Output
    Print the word "yes" if 3 divide evenly into F(n).

    Print the word "no" if not.
     
    Sample Input
    0
    1
    2
    3
    4
    5
     
    Sample Output
    no
    no
    yes
    no
    no
    no
     
     
    因为n将近1000000, 经过测试,即使用long long 64位数据存储fib数,在n为80多就会爆掉,因此,不能用一般方法处理,需要寻找其中的规律

    这种题一般情况下会有规律。把前几个能被3整除的数的下标列出来一看,规律就出现了:2 6 10 14…,这就是一个等差数列嘛,这就好办了,an = a1 + (n-1)*4,那么an-a1肯定能被4整除。代码如下:

    #include <stdio.h>

    #include <stdlib.h>

    int main(void)

    {

           int n;

           while (scanf("%d", &n) == 1)     

           {

                  if ((n-2)%4 == 0)

                         printf("yes\n");

                  else

                         printf("no\n");

           }

           return 0;

    }

    该解法如果说还可以优化的话,那只能把取余运算变为位运算了。

    if ((n-2)&3)

                         printf("no\n");

                  else

                         printf("yes\n");

    如果把数列前几项的值列出来,会发现数组中每8项构成一个循环。这也很好办。

    代码如下:

    #include <stdio.h>

    #include <stdlib.h>

    int a[8];

    int main(void)

    {

           int n;

           a[2] = a[6] = 1;

           while (scanf("%d", &n) == 1)

                  printf("%s\n", a[n%8] == 0 ? "no" : "yes" );

           return 0;

    }

    其实这个还可以优化,我们仔细观察可以看到这些满足条件的下标有一个特点:

    N%8 == 2或者n%8==6

    代码如下:

    #include <stdio.h>

    #include <stdlib.h>

    int main(void)

    {

           int n;

           while (scanf("%d", &n) == 1)

           {

                  if (n%8 == 2 || n%8 == 6)

                         printf("yes\n");

                  else

                         printf("no\n");

           }

           return 0;

    }

  • 相关阅读:
    iOS 之 创建分类
    iOS 之 动画
    iOS 倒出spa文件 打包
    js闭包
    wampserver配置多站点
    js重定向
    php obstart
    php保存远程图片
    php获取前天的昨天的日期
    weixin js接口
  • 原文地址:https://www.cnblogs.com/kkrisen/p/2796826.html
Copyright © 2011-2022 走看看