zoukankan      html  css  js  c++  java
  • HDU 1114 Piggy-Bank(完全背包)

    题目:
    Before ACM can do anything, a budget must be prepared and the necessary financial support obtained. The main income for this action comes from Irreversibly Bound Money (IBM). The idea behind is simple. Whenever some ACM member has any small money, he takes all the coins and throws them into a piggy-bank. You know that this process is irreversible, the coins cannot be removed without breaking the pig. After a sufficiently long time, there should be enough cash in the piggy-bank to pay everything that needs to be paid. 
     
    But there is a big problem with piggy-banks. It is not possible to determine how much money is inside. So we might break the pig into pieces only to find out that there is not enough money. Clearly, we want to avoid this unpleasant situation. The only possibility is to weigh the piggy-bank and try to guess how many coins are inside. Assume that we are able to determine the weight of the pig exactly and that we know the weights of all coins of a given currency. Then there is some minimum amount of money in the piggy-bank that we can guarantee. Your task is to find out this worst case and determine the minimum amount of cash inside the piggy-bank. We need your help. No more prematurely broken pigs! 
    Input
    The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers E and F. They indicate the weight of an empty pig and of the pig filled with coins. Both weights are given in grams. No pig will weigh more than 10 kg, that means 1 <= E <= F <= 10000. On the second line of each test case, there is an integer number N (1 <= N <= 500) that gives the number of various coins used in the given currency. Following this are exactly N lines, each specifying one coin type. These lines contain two integers each, Pand W (1 <= P <= 50000, 1 <= W <=10000). P is the value of the coin in monetary units, W is it's weight in grams. 
    Output
    Print exactly one line of output for each test case. The line must contain the sentence "The minimum amount of money in the piggy-bank is X." where X is the minimum amount of money that can be achieved using coins with the given total weight. If the weight cannot be reached exactly, print a line "This is impossible.".
    Sample Input
    3
    10 110
    2
    1 1
    30 50
    10 110
    2
    1 1
    50 30
    1 6
    2
    10 3
    20 4
    Sample Output
    The minimum amount of money in the piggy-bank is 60.
    The minimum amount of money in the piggy-bank is 100.
    This is impossible.
    题意:
    比较简单的完全背包,注意状态转移方程就行了
    状态转移方程: 
    dp[j] = min(dp[j],dp[j-w[i]]+p[i]) (w[i]储存的为重量)
    多的不逼逼,直接贴代码
     
    实现代码:
    #include<iostream>
    using namespace std;
    
    int main()
    {
        long long  m,x,y,p[50005],w[10005],dp[10005],i,j,wei,n;
        cin>>m;
        while(m--)
        {
            cin>>x>>y;
            wei = y - x;
            cin>>n;
            for(i=0;i<n;i++)
            {
                cin>>p[i]>>w[i];
            }
            for(i=1;i<=wei;i++)
                dp[i] =  100000000;
            dp[0] = 0;
            for(i=0;i<n;i++)
            {
                for(j=w[i];j<=wei;j++)
                {
                    dp[j] = min(dp[j],dp[j-w[i]]+p[i]);
                }
            }
            if(dp[wei] == 100000000)
                cout<<"This is impossible."<<endl;
            else
                cout<<"The minimum amount of money in the piggy-bank is "<<dp[wei]<<"."<<endl;
        }
        return 0;
    }
  • 相关阅读:
    idea的tomcat配置
    idea设置类文件的头部信息
    设置idea注释颜色
    Idea设置字体
    python 全栈开发,Day11(函数名应用,闭包,装饰器初识,带参数以及带返回值的装饰器)
    python 全栈开发,Day10(动态参数,命名空间,作用域,函数嵌套)
    python 全栈开发,Day9(函数的初始,返回值,传参,三元运算)
    python 全栈开发,Day8(文件操作)
    python 全栈开发,Day7(元组转换,列表以及字典的坑,集合,关系测试,深浅copy,编码补充)
    python 全栈开发,Day6补充(is,小数据池,编码转换)
  • 原文地址:https://www.cnblogs.com/kls123/p/6804289.html
Copyright © 2011-2022 走看看