zoukankan      html  css  js  c++  java
  • poj2586 【贪心】

    Accounting for Computer Machinists (ACM) has sufferred from the Y2K bug and lost some vital data for preparing annual report for MS Inc. 
    All what they remember is that MS Inc. posted a surplus or a deficit each month of 1999 and each month when MS Inc. posted surplus, the amount of surplus was s and each month when MS Inc. posted deficit, the deficit was d. They do not remember which or how many months posted surplus or deficit. MS Inc., unlike other companies, posts their earnings for each consecutive 5 months during a year. ACM knows that each of these 8 postings reported a deficit but they do not know how much. The chief accountant is almost sure that MS Inc. was about to post surplus for the entire year of 1999. Almost but not quite. 

    Write a program, which decides whether MS Inc. suffered a deficit during 1999, or if a surplus for 1999 was possible, what is the maximum amount of surplus that they can post.

    Input

    Input is a sequence of lines, each containing two positive integers s and d.

    Output

    For each line of input, output one line containing either a single integer giving the amount of surplus for the entire year, or output Deficit if it is impossible.

    Sample Input

    59 237
    375 743
    200000 849694
    2500000 8000000
    

    Sample Output

    116
    28
    300612
    Deficit
    思路:
    五个月内必有一次以上亏损,那么为了尽可能盈利如果五个月内4*s>d的话可以变成:oooox,oooox,oo 十二个月,盈利最大,类推一下,
    实现代码;
    #include <stdio.h>
    #include <string.h>
    #include <iostream>
    #include <algorithm>
    #include <vector>
    #include <queue>
    #include <stack>
    #include <set>
    #include <map>
    #include <string>
    #include <math.h>
    #include <stdlib.h>
    #include <bitset>
    using namespace std;
    
    #define rep(i,a,b) for (int i=(a),_ed=(b);i<=_ed;i++)
    #define per(i,a,b) for (int i=(b),_ed=(a);i>=_ed;i--)
    #define pb push_back
    #define mp make_pair
    const int inf_int = 2e9;
    const long long inf_ll = 2e18;
    #define inf_add 0x3f3f3f3f
    #define mod 1000000007
    #define ll long long
    #define ull unsigned long long
    #define ms0(X) memset((X), 0, sizeof(X)))
    #define SelfType int
    SelfType Gcd(SelfType p,SelfType q){return q==0?p:Gcd(q,p%q);}
    SelfType Pow(SelfType p,SelfType q){SelfType ans=1;while(q){if(q&1)ans=ans*p;p=p*p;q>>=1;}return ans;}
    #define Sd(X)  scanf("%d", &X)
    #define Sdd(X, Y) scanf("%d%d", &X, &Y)
    #define Sddd(X, Y, Z)  scanf("%d%d%d", &X, &Y, &Z)
    #define reunique(v) v.resize(std::unique(v.begin(), v.end()) - v.begin())
    #define all(a) a.begin(), a.end()
    #define   mem(x,v)      memset(x,v,sizeof(x))
    typedef pair<int, int> pii;
    typedef pair<long long, long long> pll;
    typedef vector<int> vi;
    typedef vector<long long> vll;
    inline int read(){int ra,fh;char rx;rx=getchar(),ra=0,fh=1;while((rx<'0'||rx>'9')&&rx!='-')rx=getchar();if(rx=='-')fh=-1,rx=getchar();while(rx>='0'&&rx<='9')ra*=10,ra+=rx-48,rx=getchar();return ra*fh;}
    //struct node{int a,b;}a[MAX][MAX];
    //bool cmp(const node &x, const node &y){return x.a>y.a;}
    
    int main()
    {
        int s,d,ans;
        while(cin>>s>>d){
            if(4*s<d)  ans = s*10-d*2;
            else if(3*s<2*d) ans = 8*s-4*d;
            else if(2*s<3*d) ans = 6*s-6*d;
            else if(s<4*d) ans = 3*s - 9*d;
            else ans = -1;
            if(ans <= 0) cout<<"Deficit"<<endl;
            else cout<<ans<<endl;
        }
        return 0;
    }
  • 相关阅读:
    JavaScript&jQuery获取url参数方法
    判断手机横屏和竖屏方向
    JS等比例缩放图片,限定最大宽度和最大高度
    某个时间周期的头天或尾天
    使用阿里云来搭建视频直播服务
    自定义View系列教程01--常用工具介绍
    C++程序设计教材目录思维导图(增C++Primer)
    Netflix OSS、Spring Cloud还是Kubernetes? 都要吧!
    php实现希尔排序
    php实现斐波那契数列
  • 原文地址:https://www.cnblogs.com/kls123/p/7358814.html
Copyright © 2011-2022 走看看