zoukankan      html  css  js  c++  java
  • hihoCoder 1631 Cats and Fish(ACM-ICPC北京赛区2017网络同步赛)

    时间限制:1000ms
    单点时限:1000ms
    内存限制:256MB

    描述

    There are many homeless cats in PKU campus. They are all happy because the students in the cat club of PKU take good care of them. Li lei is one of the members of the cat club. He loves those cats very much. Last week, he won a scholarship and he wanted to share his pleasure with cats. So he bought some really tasty fish to feed them, and watched them eating with great pleasure. At the same time, he found an interesting question:

    There are m fish and n cats, and it takes ci minutes for the ith cat to eat out one fish. A cat starts to eat another fish (if it can get one) immediately after it has finished one fish. A cat never shares its fish with other cats. When there are not enough fish left, the cat which eats quicker has higher priority to get a fish than the cat which eats slower. All cats start eating at the same time. Li Lei wanted to know, after x minutes, how many fish would be left.

    输入

    There are no more than 20 test cases.

    For each test case:

    The first line contains 3 integers: above mentioned m, n and x (0 < m <= 5000, 1 <= n <= 100, 0 <= x <= 1000).

    The second line contains n integers c1,c2 … cn,  ci means that it takes the ith cat ci minutes to eat out a fish ( 1<= ci <= 2000).

    输出

    For each test case, print 2 integers p and q, meaning that there are p complete fish(whole fish) and q incomplete fish left after x minutes.

    样例输入
    2 1 1
    1
    8 3 5
    1 3 4
    4 5 1
    5 4 3 2 1
    样例输出
    1 0
    0 1
    0 3
    心态写的爆炸,一开始想复杂了,代码乱的爆炸,怎么改怎么错,后面重新写了一份,改了半天终于过了
    题意:
    给你m条鱼,有n只猫,每只猫吃鱼的速度不同,问x秒后有多少鱼是没被吃的,有多少是没吃完的,吃的快的优先吃鱼
    思路:
    因为是吃的快的优先吃鱼,那么先将吃鱼的时间从大到小排个序,优先判断吃的快的,猫的速度为ai,那么只有当时间是ai的倍数的时候他才能完整的吃掉一条鱼,这时候我们可以用一个数组b来记录他的状态,这样最后可以通过直接便利b数组来求出有多少鱼没有被完整吃完,当时间i%ai=0的时候代表已经吃完一条鱼,此时将状态标记一下bi=0,此时代表他已经吃完了一条鱼(记录下一共吃完了多少鱼num++),现在就要再给他一条鱼,所以鱼的剩余数量cnt--,当没有鱼的时候就可以退出了。
    此时求出了一共吃完了多少鱼num,有多少鱼还没吃完(遍历b数组可得),用鱼的总数减去完全吃掉的减去没吃完的,就得到了还没吃的鱼的数量。
    实现代码:
    #include<bits/stdc++.h>
    using namespace std;
    const int M = 100050;
    #define ll long long
    
    int main()
    {
        int n,m,x,i,j,a[1009],b[1009];
       while(cin>>n>>m>>x){
       memset(b,0,sizeof(b));
       for(i=1;i<=m;i++)
        cin>>a[i];
        sort(a+1,a+1+m);
       int cnt = n;
       int num = 0;
       for(i=1;i<=x;i++){
        for(j=1;j<=m;j++){
            if(b[j]==0) cnt--;
            if(i%a[j]==0){
                b[j]=0;num++;
            }
            else b[j]=1;
            if(cnt==0) break;
        }
        if(cnt==0) break;
       }
       int ans=0;
       for(i=1;i<=m;i++)
        if(b[i]==1)
        ans++;
        cout<<n-num-ans<<" "<<ans<<endl;
       }
    
    }


  • 相关阅读:
    冒泡排序法
    选择排序法
    pyhanlp 停用词与用户自定义词典
    pyhanlp 分词与词性标注
    第八九章 正态分布与超越正态
    深入浅出统计学第七章 几何分布,二项分布,柏松分布
    深入浅出统计学 第六章 排列与组合
    深入浅出统计学 第四五章 离散概率的计算与分布
    R语言简介与案例
    深入浅出统计学 第二三章 量度
  • 原文地址:https://www.cnblogs.com/kls123/p/7863217.html
Copyright © 2011-2022 走看看