zoukankan      html  css  js  c++  java
  • poj 1511 Invitation Cards(最短路中等题)

    In the age of television, not many people attend theater performances. Antique Comedians of Malidinesia are aware of this fact. They want to propagate theater and, most of all, Antique Comedies. They have printed invitation cards with all the necessary information and with the programme. A lot of students were hired to distribute these invitations among the people. Each student volunteer has assigned exactly one bus stop and he or she stays there the whole day and gives invitation to people travelling by bus. A special course was taken where students learned how to influence people and what is the difference between influencing and robbery. 

    The transport system is very special: all lines are unidirectional and connect exactly two stops. Buses leave the originating stop with passangers each half an hour. After reaching the destination stop they return empty to the originating stop, where they wait until the next full half an hour, e.g. X:00 or X:30, where 'X' denotes the hour. The fee for transport between two stops is given by special tables and is payable on the spot. The lines are planned in such a way, that each round trip (i.e. a journey starting and finishing at the same stop) passes through a Central Checkpoint Stop (CCS) where each passenger has to pass a thorough check including body scan. 

    All the ACM student members leave the CCS each morning. Each volunteer is to move to one predetermined stop to invite passengers. There are as many volunteers as stops. At the end of the day, all students travel back to CCS. You are to write a computer program that helps ACM to minimize the amount of money to pay every day for the transport of their employees. 

    Input

    The input consists of N cases. The first line of the input contains only positive integer N. Then follow the cases. Each case begins with a line containing exactly two integers P and Q, 1 <= P,Q <= 1000000. P is the number of stops including CCS and Q the number of bus lines. Then there are Q lines, each describing one bus line. Each of the lines contains exactly three numbers - the originating stop, the destination stop and the price. The CCS is designated by number 1. Prices are positive integers the sum of which is smaller than 1000000000. You can also assume it is always possible to get from any stop to any other stop.

    Output

    For each case, print one line containing the minimum amount of money to be paid each day by ACM for the travel costs of its volunteers.

    Sample Input

    2
    2 2
    1 2 13
    2 1 33
    4 6
    1 2 10
    2 1 60
    1 3 20
    3 4 10
    2 4 5
    4 1 50

    Sample Output

    46
    210

    思路:思路不难只要多建一个逆序图,求出他的最短路加上之前正序图的最短路,就是答案,难点只要是数据太大容易爆容量和超时。所以选择链式前向星+spfa来实现。
    实现代码:
    #include<iostream>
    #include<cstdio>
    #include<queue>
    #include<cstring>
    using namespace std;
    #define ll long long
    #define M  1000100
    #define INF 0x3f3f3f3f
    int dist[M],vis[M],head[M],x[M],y[M],z[M],cnt,n;
    struct edge{
        int to,w,next;
    }edge[M];
    void add(int u,int v,int w){
        edge[cnt].next = head[u];
        edge[cnt].to = v;
        edge[cnt].w = w;
        head[u] = cnt++;
    }
    void spfa(int s){
        memset(vis,0,sizeof(vis));
        for(int i = 1;i <= n; i++) dist[i] = INF;
        dist[s] = 0;
        queue<int>q;
        q.push(s);
        while(!q.empty()){
            int u = q.front(); q.pop();
            vis[u] = 0;
            for(int k = head[u]; k ;k = edge[k].next){
                int v = edge[k].to;
                if(dist[v] >  dist[u] + edge[k].w){
                    dist[v] = dist[u] + edge[k].w;
                    if(!vis[v]){
                        vis[v] = 1;
                        q.push(v);
                    }
                }
            }
        }
    }
    
    int main(){
        int t,m;
        while(scanf("%d",&t)!=EOF){
            while(t--){
            memset(head,0,sizeof(head));
            memset(edge,0,sizeof(edge));
            scanf("%d%d",&n,&m);
            cnt = 1;
            for(int i = 1;i <= m; i++){
                scanf("%d%d%d",&x[i],&y[i],&z[i]);
                add(x[i],y[i],z[i]);
            }
            spfa(1);
            ll ans = 0;
            for(int i = 1;i <= n; i++){
                ans += dist[i];
                //cout<<dist[i]<<endl;
            }
            memset(head,0,sizeof(head));
            memset(edge,0,sizeof(edge));
            cnt = 1;
            for(int i = 1;i <= m; i++){
                add(y[i],x[i],z[i]);
            }
            spfa(1);
            for(int i = 1;i <= n; i++){
                ans += dist[i];
                //cout<<dist[i]<<endl;
            }
            cout<<ans<<endl;
            }
        }
    }
  • 相关阅读:
    poj3475
    poj2665
    poj2583
    poj2656
    【API进阶之路】破圈,用一个API代替10人内容团队
    除了方文山,用TA你也能帮周杰伦写歌词了
    敏捷转型谁先动:老总,项目经理or团队
    实战案例丨使用云连接CC和数据复制服务DRS实现跨区域RDS迁移和数据同步
    9块钱,构建个私有网盘,关键不限速
    终端传感了解吗?18个知识点为你扫盲
  • 原文地址:https://www.cnblogs.com/kls123/p/7994696.html
Copyright © 2011-2022 走看看