zoukankan      html  css  js  c++  java
  • ACM HDU 1008 Elevator

    Elevator

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 16549    Accepted Submission(s): 8795


    Problem Description
    The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

    For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.
     

    Input
    There are multiple test cases. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100. A test case with N = 0 denotes the end of input. This test case is not to be processed.
     

    Output
    Print the total time on a single line for each test case.
     

    Sample Input
    1 2 3 2 3 1 0
     

    Sample Output
    17 41
     

    Author
    ZHENG, Jianqiang
     

    Source
     

    Recommend
    JGShining
     
    水题:
    #include<stdio.h>
    int main()
    {
    int n;
    int start,a;
    int t;
    int i;
    while(scanf("%d",&n),n)
    {
    t
    =0;start=0;
    for(int i=1;i<=n;i++)
    {
    scanf(
    "%d",&a);
    if(a>start)t+=6*(a-start);
    else t+=4*(start-a);
    t
    +=5;
    start
    =a;
    }
    printf(
    "%d\n",t);
    }
    return 0;
    }

  • 相关阅读:
    linux内存不足导致java进程被kill掉
    记一次centos服务器DNS引起的网络问题
    记consul集群和spring cloud集成遇到的问题。
    记一次url未encode遇到的问题
    十六周总结
    十五周总结
    计算最长英语单词链
    大道至简阅读笔记02
    大道至简阅读笔记01
    用户体验评价之搜狗输入法
  • 原文地址:https://www.cnblogs.com/kuangbin/p/2118678.html
Copyright © 2011-2022 走看看