zoukankan      html  css  js  c++  java
  • ACM HDU 1014 Uniform Generator

    Uniform Generator

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 6215    Accepted Submission(s): 2477


    Problem Description
    Computer simulations often require random numbers. One way to generate pseudo-random numbers is via a function of the form

    seed(x+1) = [seed(x) + STEP] % MOD

    where '%' is the modulus operator.

    Such a function will generate pseudo-random numbers (seed) between 0 and MOD-1. One problem with functions of this form is that they will always generate the same pattern over and over. In order to minimize this effect, selecting the STEP and MOD values carefully can result in a uniform distribution of all values between (and including) 0 and MOD-1.

    For example, if STEP = 3 and MOD = 5, the function will generate the series of pseudo-random numbers 0, 3, 1, 4, 2 in a repeating cycle. In this example, all of the numbers between and including 0 and MOD-1 will be generated every MOD iterations of the function. Note that by the nature of the function to generate the same seed(x+1) every time seed(x) occurs means that if a function will generate all the numbers between 0 and MOD-1, it will generate pseudo-random numbers uniformly with every MOD iterations.

    If STEP = 15 and MOD = 20, the function generates the series 0, 15, 10, 5 (or any other repeating series if the initial seed is other than 0). This is a poor selection of STEP and MOD because no initial seed will generate all of the numbers from 0 and MOD-1.

    Your program will determine if choices of STEP and MOD will generate a uniform distribution of pseudo-random numbers.
     

    Input
    Each line of input will contain a pair of integers for STEP and MOD in that order (1 <= STEP, MOD <= 100000).
     

    Output
    For each line of input, your program should print the STEP value right- justified in columns 1 through 10, the MOD value right-justified in columns 11 through 20 and either "Good Choice" or "Bad Choice" left-justified starting in column 25. The "Good Choice" message should be printed when the selection of STEP and MOD will generate all the numbers between and including 0 and MOD-1 when MOD numbers are generated. Otherwise, your program should print the message "Bad Choice". After each output test set, your program should print exactly one blank line.
     

    Sample Input
    3 5 15 20 63923 99999
     

    Sample Output
    3 5 Good Choice 15 20 Bad Choice 63923 99999 Good Choice
     

    Source
     

    Recommend
    JGShining
     
    #include<stdio.h>
    #include<iostream>
    #include<string.h>
    using namespace std;
    int f[100000];
    int main()
    {
        int step,mod;
        int i,a;
        bool cnt;
    
        while(scanf("%d%d",&step,&mod)!=EOF)
        {
            memset(f,0,sizeof(f));
            cnt=true;
            a=0;
            f[a]++;
            for(i=1;i<mod;i++)
            {
                a=(a+step)%mod;
                f[a]++;
                if(f[a]>=2){cnt=false;break;}
            }  
            
            printf("%10d%10d    ",step,mod);
            if(cnt)printf("Good Choice\n\n");
            else printf("Bad Choice\n\n");  
        
        }   
        return 0; 
    }   
    

     
  • 相关阅读:
    学习js笔记(第3章-语句和严格模式)
    学习js笔记(1,2章)
    学习闭包
    JavaScript 内存泄漏
    jQuery基础(四)—动画篇
    网站性能优化之yahoo军规
    webpack打包vue文件报错:Module parse failed: Unexpected token (1:0)
    PHP图片转为webp格式
    postman在phpstorm使用xdebug调试
    charles抓取手机APP,配置正确却抓不到数据
  • 原文地址:https://www.cnblogs.com/kuangbin/p/2119013.html
Copyright © 2011-2022 走看看