zoukankan      html  css  js  c++  java
  • ACM HDU 1017 A Mathematical Curiosity

    A Mathematical Curiosity

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 10942    Accepted Submission(s): 3371


    Problem Description
    Given two integers n and m, count the number of pairs of integers (a,b) such that 0 < a < b < n and (a^2+b^2 +m)/(ab) is an integer.

    This problem contains multiple test cases!

    The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

    The output format consists of N output blocks. There is a blank line between output blocks.
     

    Input
    You will be given a number of cases in the input. Each case is specified by a line containing the integers n and m. The end of input is indicated by a case in which n = m = 0. You may assume that 0 < n <= 100.
     

    Output
    For each case, print the case number as well as the number of pairs (a,b) satisfying the given property. Print the output for each case on one line in the format as shown below.
     

    Sample Input
    1 10 1 20 3 30 4 0 0
     

    Sample Output
    Case 1: 2 Case 2: 4 Case 3: 5
     

    Source
     

    Recommend
    JGShining
     
     
    #include<stdio.h>
    int main()
    {
    int T,i,j;
    int cnt;
    int n,m;
    int icase;
    scanf(
    "%d",&T);
    while(T--)
    {
    icase
    =1;
    while(scanf("%d%d",&n,&m))
    {
    cnt
    =0;
    if(n==0&&m==0)break;
    for(i=1;i<n;i++)
    for(j=i+1;j<n;j++)
    if((i*i+j*j+m)%(i*j)==0)cnt++;
    printf(
    "Case %d: %d\n",icase++,cnt);
    }
    if(T>0)printf("\n");
    }
    return 0;
    }

  • 相关阅读:
    Ext Form
    Ext中 get、getDom、getCmp的区别
    Ext.state.Manager.setProvider(new Ext.state.CookieProvider())
    Ext BoxComponent
    Ext表单提示方式:msgTarget
    Ext.QuickTips.init()的使用
    Ext.Ajax.Request
    FitLayout
    视图Ext.Viewport和窗口Ext.Window用法
    禁用IE缓存
  • 原文地址:https://www.cnblogs.com/kuangbin/p/2119829.html
Copyright © 2011-2022 走看看