zoukankan      html  css  js  c++  java
  • ACM HDU 1164 Eddy's research I(素数分解,水题)

    Eddy's research I

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 2443    Accepted Submission(s): 1492


    Problem Description
    Eddy's interest is very extensive, recently he is interested in prime number. Eddy discover the all number owned can be divided into the multiply of prime number, but he can't write program, so Eddy has to ask intelligent you to help him, he asks you to write a program which can do the number to divided into the multiply of prime number factor .

     

    Input
    The input will contain a number 1 < x<= 65535 per line representing the number of elements of the set.
     

    Output
    You have to print a line in the output for each entry with the answer to the previous question.
     

    Sample Input
    11 9412
     

    Sample Output
    11 2*2*13*181
     

    Author
    eddy
     

    Recommend
    JGShining
     
     
    很简单,不解释了,看代码!
     
    #include<stdio.h>
    bool notprime[65536];
    void calc()
    {
    for(int i=2;i<=256;i++)
    if(notprime[i]==0)
    for(int j=i+i;j<=65535;j+=i)
    notprime[j]
    =1;
    }
    int solve(int k,int n)//得到n的>=k的素数因子
    {
    for(int i=k;i<=256;i++)
    if(notprime[i]==0)
    if(n%i==0)
    return i;
    }
    int main()
    {
    int n,i,j;
    calc();
    while(scanf("%d",&n)!=EOF)
    {
    int k=2;
    while(notprime[n])
    {
    k
    =solve(k,n);
    printf(
    "%d*",k);
    n
    /=k;
    }
    printf(
    "%d\n",n);
    }
    return 0;
    }

  • 相关阅读:
    pgsql查询优化之模糊查询
    两款不同应用场景的Wpf分页控件
    C# 客户端程序调用外部程序的三种实现
    WPF DataGrid自动生成序号
    WPF控件自适应屏幕
    NOPI实现导入导出泛型List,支持自定义列
    WPF蒙板弹窗
    定时发送邮件
    数据库基础知识介绍(MySQL)
    动态数据透视表
  • 原文地址:https://www.cnblogs.com/kuangbin/p/2124191.html
Copyright © 2011-2022 走看看