zoukankan      html  css  js  c++  java
  • HDU 1087 Super Jumping! Jumping! Jumping! (求最大上升子序列和,动态规划)

    Super Jumping! Jumping! Jumping!

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 9053    Accepted Submission(s): 3693


    Problem Description
    Nowadays, a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popular in HDU. Maybe you are a good boy, and know little about this game, so I introduce it to you now.



    The game can be played by two or more than two players. It consists of a chessboard(棋盘)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In the course of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping can go from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his jumping solution. Note that your score comes from the sum of value on the chessmen in you jumping path.
    Your task is to output the maximum value according to the given chessmen list.
     

    Input
    Input contains multiple test cases. Each test case is described in a line as follow:
    N value_1 value_2 …value_N
    It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int.
    A test case starting with 0 terminates the input and this test case is not to be processed.
     

    Output
    For each case, print the maximum according to rules, and one line one case.
     

    Sample Input
    3 1 3 2 4 1 2 3 4 4 3 3 2 1 0
     

    Sample Output
    4 10 3
     

    Author
    lcy
     
     
    /*
    HDU1087
    就是找一个上升子序列,使和最大
    */
    #include<stdio.h>
    #include<algorithm>
    #define MAXN 1000
    using namespace std;
    int a[MAXN+10];
    int dp[MAXN+10];//dp[i]表示以a[i]结束的最大的上升子序列的和
    int main()
    {
        int n,i,j;
        int maxsum;
        while(scanf("%d",&n),n)
        {
            for(i=1;i<=n;i++)
            {
                scanf("%d",&a[i]);
                dp[i]=a[i];
            }
            maxsum=0;
            for(i=1;i<=n;i++)
            {
                for(j=1;j<i;j++)
                   if(a[j]<a[i]&&dp[j]+a[i]>dp[i])
                      dp[i]=dp[j]+a[i];
                if(dp[i]>maxsum)  maxsum=dp[i];
            }      
            printf("%d\n",maxsum);
        }
        return 0;   
    }    
  • 相关阅读:
    How to build Linux system from kernel to UI layer
    Writing USB driver for Android
    Xposed Framework for Android 8.x Oreo is released (in beta)
    Linux Smartphone Operating Systems You Can Install Today
    Librem 5 Leads New Wave of Open Source Mobile Linux Contenders
    GUADEC: porting GNOME to Android
    Librem 5 – A Security and Privacy Focused Phone
    GNOME and KDE Join Librem 5 Linux Smartphone Party
    Purism计划推出安全开源的Linux Librem 5智能手机
    国产系统之殇:你知道的这些系统都是国外的
  • 原文地址:https://www.cnblogs.com/kuangbin/p/2127422.html
Copyright © 2011-2022 走看看