zoukankan      html  css  js  c++  java
  • ACM HDU 3354 Probability One(简单题)

    Probability One

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 301    Accepted Submission(s): 224


    Problem Description
    Number guessing is a popular game between elementary-school kids. Teachers encourage pupils to play the game as it enhances their arithmetic skills, logical thinking, and following-up simple procedures. We think that, most probably, you too will master in few minutes. Here’s one example of how you too can play this game: Ask a friend to think of a number, let’s call it n0.
    Then:
    1. Ask your friend to compute n1 = 3 * n0 and to tell you if n1 is even or odd.
    2. If n1 is even, ask your friend to compute n2 = n1/2. If, otherwise, n1 was odd then let your friend compute n2 = (n1 + 1)/2.
    3. Now ask your friend to calculate n3 = 3 * n2.
    4. Ask your friend to tell tell you the result of n4 = n3/9. (n4 is the quotient of the division operation. In computer lingo, ’/’ is the integer-division operator.)
    5. Now you can simply reveal the original number by calculating n0 = 2 * n4 if n1 was even, or n0 = 2 * n4 + 1 otherwise.
    Here’s an example that you can follow: If n0 = 37, then n1 = 111 which is odd. Now we can calculate n2 = 56, n3= 168, and n4 = 18, which is what your friend will tell you. Doing the calculation 2 × n4 + 1 = 37 reveals n0.
     

    Input
    Your program will be tested on one or more test cases. Each test case is made of a single positive number (0 < n0 < 1, 000, 000).
    The last line of the input file has a single zero (which is not part of the test cases.)
     

    Output
    For each test case, print the following line:
    k. B Q
    Where k is the test case number (starting at one,) B is either ’even’ or ’odd’ (without the quotes) depending on your friend’s answer in step 1. Q is your friend’s answer to step 4.
    Note: There is a blank space before B.
     

    Sample Input
    37 38 0
     

    Sample Output
    1. odd 18 2. even 19
     

    Source
     

    Recommend
    lcy
     
     
    #include<stdio.h>
    int main()
    {
    int n0;
    int iCase=0;
    while(scanf("%d",&n0),n0)
    {
    iCase
    ++;
    printf(
    "%d. ",iCase);
    if(n0%2==0)
    printf(
    "even %d\n",n0/2);
    else
    printf(
    "odd %d\n",(n0-1)/2);
    }
    return 0;
    }

  • 相关阅读:
    mvc form
    mvc Action上面加 [HttpPost]
    存储过程
    tj
    第25月第18天 vue
    第25月第17天 django rest framwork authentication /tmp/mysql.sock
    第25月第15天 udacity cs253
    第25月第11天 deeplearning.ai
    第25月第9天 tf_tang_poems kaggle
    第25月第8天 100-Days-Of-ML-Code
  • 原文地址:https://www.cnblogs.com/kuangbin/p/2155670.html
Copyright © 2011-2022 走看看