zoukankan      html  css  js  c++  java
  • ACM HDU 2509 Be the Winner(博弈)

    Be the Winner

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 504    Accepted Submission(s): 247


    Problem Description
    Let's consider m apples divided into n groups. Each group contains no more than 100 apples, arranged in a line. You can take any number of consecutive apples at one time.
    For example "@@@" can be turned into "@@" or "@" or "@ @"(two piles). two people get apples one after another and the one who takes the last is
    the loser. Fra wants to know in which situations he can win by playing strategies (that is, no matter what action the rival takes, fra will win).
     

    Input
    You will be given several cases. Each test case begins with a single number n (1 <= n <= 100), followed by a line with n numbers, the number of apples in each pile. There is a blank line between cases.
     

    Output
    If a winning strategies can be found, print a single line with "Yes", otherwise print "No".
     

    Sample Input
    2 2 2 1 3
     

    Sample Output
    No Yes
     

    Source
     

    Recommend
    lcy
     
     
    和HDU1907是一样的题目。详细解释看:
     
     
    代码:
    #include<stdio.h>
    int a[105];
    int main()
    {
    int i,ans,n,temp;
    while(scanf("%d",&n)!=EOF)
    {
    temp
    =0;//孤单堆
    for(i=0;i<n;i++)
    {
    scanf(
    "%d",&a[i]);
    if(i==0)
    ans
    =a[i];
    else
    ans
    =ans^a[i];
    if(a[i]>1) temp=1;
    }
    if(temp==0)
    {
    if(n%2==1)
    printf(
    "No\n");
    else
    printf(
    "Yes\n");
    continue;
    }
    if(ans==0)
    printf(
    "No\n");
    else
    printf(
    "Yes\n");
    }
    return 0;
    }
  • 相关阅读:
    ubuntu video and audio
    js type
    jumpserver 堡垒机环境搭建
    ubuntu dnsmasq
    bind--dns-docker---[nslookup/dig]
    java maven scope compile,provide,system,test,runtime
    docker install and minikube install
    nginx break-circus orange api-gateway
    一个IP能建立的最大连接数是多少?
    Docker 在6.4上安装
  • 原文地址:https://www.cnblogs.com/kuangbin/p/2158326.html
Copyright © 2011-2022 走看看